summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/mp3burn/mp3burn-0.4.2.ebuild')
-rw-r--r--app-cdr/mp3burn/mp3burn-0.4.2.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/app-cdr/mp3burn/mp3burn-0.4.2.ebuild b/app-cdr/mp3burn/mp3burn-0.4.2.ebuild
index a909d1a93579..b5af79302672 100644
--- a/app-cdr/mp3burn/mp3burn-0.4.2.ebuild
+++ b/app-cdr/mp3burn/mp3burn-0.4.2.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/mp3burn/mp3burn-0.4.2.ebuild,v 1.3 2012/03/25 17:02:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/mp3burn/mp3burn-0.4.2.ebuild,v 1.4 2015/07/08 19:00:06 pacho Exp $
+
+EAPI=5
+inherit eutils
DESCRIPTION="Burn mp3s without filling up your disk with .wav files"
HOMEPAGE="http://sourceforge.net/projects/mp3burn"
@@ -19,16 +22,17 @@ RDEPEND="${DEPEND}
virtual/cdrtools
dev-perl/MP3-Info
dev-perl/ogg-vorbis-header
- dev-perl/String-ShellQuote"
+ dev-perl/String-ShellQuote
+"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
-src_compile() {
- emake || die "emake failed"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
}
src_install() {
- dobin ${PN} || die "dobin failed"
+ dobin ${PN}
doman ${PN}.1
- dodoc Changelog README
+ einstalldocs
}