summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/easy-rsa/easy-rsa-2.2.0.ebuild')
-rw-r--r--app-crypt/easy-rsa/easy-rsa-2.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/easy-rsa/easy-rsa-2.2.0.ebuild b/app-crypt/easy-rsa/easy-rsa-2.2.0.ebuild
new file mode 100644
index 000000000000..689863f4545f
--- /dev/null
+++ b/app-crypt/easy-rsa/easy-rsa-2.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/easy-rsa/easy-rsa-2.2.0.ebuild,v 1.1 2013/01/24 09:49:12 djc Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs flag-o-matic
+
+DESCRIPTION="Small RSA key management package, based on OpenSSL."
+HOMEPAGE="http://openvpn.net/"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="http://swupdate.openvpn.net/community/releases/${P}_master.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/openssl-0.9.6"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}_master"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.0-pkcs11.patch"
+}
+
+src_configure() {
+ econf --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doenvd "${FILESDIR}/65easy-rsa" # config-protect easy-rsa
+}