summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/doxygen/doxygen-1.5.7.1.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-1.5.7.1.ebuild31
1 files changed, 7 insertions, 24 deletions
diff --git a/app-doc/doxygen/doxygen-1.5.7.1.ebuild b/app-doc/doxygen/doxygen-1.5.7.1.ebuild
index 61f13caf6c68..e0cb88516f90 100644
--- a/app-doc/doxygen/doxygen-1.5.7.1.ebuild
+++ b/app-doc/doxygen/doxygen-1.5.7.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.7.1.ebuild,v 1.5 2009/12/26 17:24:39 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.7.1.ebuild,v 1.6 2010/01/02 22:22:09 yngwin Exp $
EAPI=1
-inherit eutils flag-o-matic toolchain-funcs qt3 fdo-mime
+inherit eutils flag-o-matic toolchain-funcs fdo-mime
DESCRIPTION="documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages"
HOMEPAGE="http://www.doxygen.org/"
@@ -13,10 +13,9 @@ SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc nodot qt3 latex elibc_FreeBSD"
+IUSE="debug doc nodot latex elibc_FreeBSD"
-RDEPEND="qt3? ( x11-libs/qt:3 )
- latex? ( app-text/texlive-core
+RDEPEND="latex? ( app-text/texlive-core
dev-texlive/texlive-genericrecommended
dev-texlive/texlive-fontsrecommended
dev-texlive/texlive-latexrecommended
@@ -90,17 +89,7 @@ src_compile() {
my_conf="--prefix /usr"
fi
- if use qt3; then
- einfo "using QTDIR: '$QTDIR'."
- export LIBRARY_PATH="${QTDIR}/$(get_libdir):${LIBRARY_PATH}"
- export LD_LIBRARY_PATH="${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}"
- einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
- einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
- ./configure ${my_conf} $(use_with qt3 doxywizard) \
- || die 'configure with qt3 failed'
- else
- ./configure ${my_conf} || die 'configure failed'
- fi
+ ./configure ${my_conf} || die 'configure failed'
# and compile
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
@@ -138,12 +127,6 @@ src_install() {
make DESTDIR="${D}" MAN1DIR=share/man/man1 \
install || die '"make install" failed.'
- if use qt3; then
- doicon "${FILESDIR}/doxywizard.png"
- make_desktop_entry doxywizard "DoxyWizard ${PV}" \
- "doxywizard.png" "Application;Development"
- fi
-
dodoc INSTALL LANGUAGE.HOWTO README
# pdf and html manuals
@@ -160,7 +143,7 @@ pkg_postinst() {
fdo-mime_desktop_database_update
elog
- elog "The USE flags qt3, doc, and latex will enable doxywizard, or"
+ elog "The USE flags doc, and latex will enable"
elog "the html and pdf documentation, respectively. For examples"
elog "and other goodies, see the source tarball. For some example"
elog "output, run doxygen on the doxygen source using the Doxyfile"