summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/fte/fte-20010819-r2.ebuild')
-rw-r--r--app-editors/fte/fte-20010819-r2.ebuild68
1 files changed, 34 insertions, 34 deletions
diff --git a/app-editors/fte/fte-20010819-r2.ebuild b/app-editors/fte/fte-20010819-r2.ebuild
index 6e253d19ab91..4f80602f2169 100644
--- a/app-editors/fte/fte-20010819-r2.ebuild
+++ b/app-editors/fte/fte-20010819-r2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20010819-r2.ebuild,v 1.6 2002/07/25 19:12:09 kabau Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20010819-r2.ebuild,v 1.7 2002/08/02 05:05:01 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Lightweight text-mode editor"
SRC_URI="mirror://sourceforge/fte/fte-20010819-src.zip
- mirror://sourceforge/fte/fte-20010819-common.zip"
+ mirror://sourceforge/fte/fte-20010819-common.zip"
HOMEPAGE="http://fte.sourceforge.net"
@@ -26,68 +26,68 @@ LICENSE="GPL"
KEYWORDS="x86"
if [ "`use slang`" ] ; then
- TARGETS="$TARGETS sfte"
+ TARGETS="$TARGETS sfte"
fi
if [ "`use X`" ] ; then
- TARGETS="$TARGETS xfte"
+ TARGETS="$TARGETS xfte"
fi
if [ "`use gpm`" ] ; then
- TARGETS="$TARGETS vfte"
+ TARGETS="$TARGETS vfte"
fi
src_unpack() {
- cd ${WORKDIR}
- unpack fte-20010819-src.zip
- unpack fte-20010819-common.zip
+ cd ${WORKDIR}
+ unpack fte-20010819-src.zip
+ unpack fte-20010819-common.zip
- mv fte fte-20010819
+ mv fte fte-20010819
- cd ${S}; patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ cd ${S}; patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
- cp src/fte-unix.mak src/fte-unix.mak.orig
+ cp src/fte-unix.mak src/fte-unix.mak.orig
- cat src/fte-unix.mak.orig | \
- sed "s/@targets@/${TARGETS}/" | \
- sed "s/@cflags@/${CFLAGS}/" \
- > src/fte-unix.mak
+ cat src/fte-unix.mak.orig | \
+ sed "s/@targets@/${TARGETS}/" | \
+ sed "s/@cflags@/${CFLAGS}/" \
+ > src/fte-unix.mak
}
src_compile() {
- emake all || die
+ emake all || die
- cd config
- ../src/cfte main.fte ../src/system.fterc
+ cd config
+ ../src/cfte main.fte ../src/system.fterc
}
src_install () {
- local files
- into /usr
+ local files
+ into /usr
- files="${TARGETS} cfte compkeys"
+ files="${TARGETS} cfte compkeys"
- for i in ${files} ; do
- dobin src/$i ;
- done
+ for i in ${files} ; do
+ dobin src/$i ;
+ done
- dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
-
- dodir etc/fte
- cp src/system.fterc ${D}/etc/fte/system.fterc
+ dodoc Artistic CHANGES BUGS COPYING HISTORY README TODO
+
+ dodir etc/fte
+ cp src/system.fterc ${D}/etc/fte/system.fterc
- dodir usr/share/doc/${P}/html
- cp doc/INDEX doc/*.html ${D}/usr/share/doc/${P}/html
+ dodir usr/share/doc/${P}/html
+ cp doc/INDEX doc/*.html ${D}/usr/share/doc/${P}/html
# if [ -a ${D}/usr/bin/xfte ] ; then
# into /usr/X11R6 ;
# dobin src/xfte ;
# rm ${D}/usr/bin/xfte ;
# fi
-
- dodir usr/share/fte
- cp -R config/* ${D}/usr/share/fte
- rm -rf ${D}/usr/share/fte/CVS
+
+ dodir usr/share/fte
+ cp -R config/* ${D}/usr/share/fte
+ rm -rf ${D}/usr/share/fte/CVS
}