summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/zile/zile-2.3.0.ebuild')
-rw-r--r--app-editors/zile/zile-2.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-editors/zile/zile-2.3.0.ebuild b/app-editors/zile/zile-2.3.0.ebuild
new file mode 100644
index 000000000000..e32f73bd3bae
--- /dev/null
+++ b/app-editors/zile/zile-2.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.3.0.ebuild,v 1.1 2008/12/16 11:39:33 ulm Exp $
+
+inherit eutils
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="http://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3 FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-libs/ncurses
+ >=sys-apps/texinfo-4.3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-splash.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS NEWS README THANKS || die "dodoc failed"
+}