summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/spim/spim-7.3.ebuild')
-rw-r--r--app-emulation/spim/spim-7.3.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/app-emulation/spim/spim-7.3.ebuild b/app-emulation/spim/spim-7.3.ebuild
index a57a6eb7cec8..13400b573f19 100644
--- a/app-emulation/spim/spim-7.3.ebuild
+++ b/app-emulation/spim/spim-7.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spim/spim-7.3.ebuild,v 1.7 2008/01/11 20:55:19 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spim/spim-7.3.ebuild,v 1.8 2009/03/20 03:25:56 jmbsvicetto Exp $
inherit eutils toolchain-funcs
@@ -23,16 +23,16 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Fix documentation files
- cd ${S}/Documentation
+ cd "${S}/Documentation"
mv spim.man spim.1
mv xspim.man xspim.1
}
src_compile() {
- cd ${S}/spim
+ cd "${S}/spim"
./Configure || die "Configure Failed!"
@@ -49,7 +49,7 @@ src_compile() {
emake CC="$(tc-getCC)" || die
if use X ; then
- cd ${S}/xspim
+ cd "${S}/xspim"
./Configure || die "Configure Failed!"
@@ -67,7 +67,7 @@ src_compile() {
}
src_test() {
- cd ${S}/spim
+ cd "${S}/spim"
make test || die "Failed to pass tests!"
}
@@ -76,21 +76,21 @@ src_install() {
dodir /usr/share/man
dodir /var/lib/spim
- cd ${S}/spim
+ cd "${S}/spim"
make install DESTDIR="${D}" || die "Unable to install spim"
if use X ; then
- cd ${S}/xspim
+ cd "${S}/xspim"
make DESTDIR="${D}" install || die "Unable to install xspim"
fi
- cd ${S}/Documentation
+ cd "${S}/Documentation"
doman spim.1
use X && doman xspim.1
dohtml SPIM.html
dodoc BLURB
- cd ${S}
+ cd "${S}"
dodoc README VERSION ChangeLog
}