summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-monocle/lc-monocle-0.6.0.ebuild')
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-0.6.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-leechcraft/lc-monocle/lc-monocle-0.6.0.ebuild b/app-leechcraft/lc-monocle/lc-monocle-0.6.0.ebuild
new file mode 100644
index 000000000000..64422e62592f
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-0.6.0.ebuild,v 1.1 2013/09/24 15:48:06 maksbotan Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +djvu doc +fb2 +pdf +spectre"
+
+RDEPEND="~app-leechcraft/lc-core-${PV}
+ pdf? ( app-text/poppler[qt4] )
+ djvu? ( app-text/djvu )
+ spectre? ( app-text/libspectre )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable pdf MONOCLE_PDF)
+ $(cmake-utils_use_enable spectre MONOCLE_POSTRUS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+}