summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/task/files/task-1.9.4-lua-automagic.patch')
-rw-r--r--app-misc/task/files/task-1.9.4-lua-automagic.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/task/files/task-1.9.4-lua-automagic.patch b/app-misc/task/files/task-1.9.4-lua-automagic.patch
new file mode 100644
index 000000000000..4d29766214a6
--- /dev/null
+++ b/app-misc/task/files/task-1.9.4-lua-automagic.patch
@@ -0,0 +1,27 @@
+--- task-1.9.4/CMakeLists.txt.orig
++++ task-1.9.4/CMakeLists.txt
+@@ -30,14 +30,16 @@
+ set (PACKAGE_VERSION "${VERSION}")
+ set (PACKAGE_STRING "${PACKAGE} ${VERSION}")
+
+-message ("-- Looking for Lua51")
+-find_package (Lua51)
+-if (LUA51_FOUND)
+- message ("-- Found Lua51: ${LUA_LIBRARIES}")
+- set (HAVE_LIBLUA true)
+- set (TASK_INCLUDE_DIRS ${TASK_INCLUDE_DIRS} ${LUA_INCLUDE_DIR})
+- set (TASK_LIBRARIES ${TASK_LIBRARIES} ${LUA_LIBRARIES})
+-endif (LUA51_FOUND)
++if( ENABLE_LUA )
++ message ("-- Looking for Lua51")
++ find_package (Lua51)
++ if (LUA51_FOUND)
++ message ("-- Found Lua51: ${LUA_LIBRARIES}")
++ set (HAVE_LIBLUA true)
++ set (TASK_INCLUDE_DIRS ${TASK_INCLUDE_DIRS} ${LUA_INCLUDE_DIR})
++ set (TASK_LIBRARIES ${TASK_LIBRARIES} ${LUA_LIBRARIES})
++ endif (LUA51_FOUND)
++endif (ENABLE_LUA )
+
+ message ("-- Looking for pthread")
+ find_path (PTHREAD_INCLUDE_DIR pthread.h)