summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/qhacc/qhacc-3.2.1.ebuild')
-rw-r--r--app-office/qhacc/qhacc-3.2.1.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/app-office/qhacc/qhacc-3.2.1.ebuild b/app-office/qhacc/qhacc-3.2.1.ebuild
index 3aa18d342842..d50469ccc1b4 100644
--- a/app-office/qhacc/qhacc-3.2.1.ebuild
+++ b/app-office/qhacc/qhacc-3.2.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/qhacc/qhacc-3.2.1.ebuild,v 1.3 2004/10/11 23:01:13 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/qhacc/qhacc-3.2.1.ebuild,v 1.4 2004/10/14 00:21:47 carlo Exp $
inherit libtool kde-functions eutils
-DESCRIPTION="Personal Finance for QT"
+DESCRIPTION="Personal Finance for Qt"
HOMEPAGE="http://qhacc.sourceforge.net/"
SRC_URI="mirror://sourceforge/qhacc/${P}.tar.gz"
@@ -21,9 +21,14 @@ RDEPEND="mysql? ( dev-db/mysql++ )
sqlite? ( dev-db/sqlite )"
need-qt 3
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
elibtoolize
+ epatch ${FILESDIR}/${P}-sandbox.patch
+}
+src_compile() {
local myconf="--libdir=/usr/lib/qhacc --bindir=/usr/bin --includedir=/usr/include --datadir=/usr/share/qhacc
$(use_enable mysql)
$(use_enable postgres psql)
@@ -52,10 +57,10 @@ src_install() {
}
pkg_postinst() {
- echo
+ echo ""
einfo "A sample configuration is provided in /usr/share/qhacc/easysetup."
einfo "copy files: \`mkdir ~/.qhacc ; cp /usr/share/qhacc/easysetup/* ~/.qhacc\`"
einfo "run program: \`qhacc -f ~/.qhacc/\`"
einfo "set alias: \`echo -e \\\n \"alias qhacc=\\\"qhacc -f ~/.qhacc\\\"\" >> ~/.bashrc\`"
- echo
+ echo ""
}