summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/qcad/qcad-2.0.0.1.ebuild')
-rw-r--r--app-sci/qcad/qcad-2.0.0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-sci/qcad/qcad-2.0.0.1.ebuild b/app-sci/qcad/qcad-2.0.0.1.ebuild
new file mode 100644
index 000000000000..ef48c0aafcc3
--- /dev/null
+++ b/app-sci/qcad/qcad-2.0.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $ $
+inherit kde-functions
+
+MY_P=${P}-1.src
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A 2D CAD package based upon Qt."
+SRC_URI="http://www.ribbonsoft.com/archives/qcad/${MY_P}.tar.gz"
+HOMEPAGE="http://www.ribbonsoft.com/qcad.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+need-qt 3
+
+DEPEND="${DEPEND}
+ >=sys-apps/sed-4"
+
+src_compile() {
+ cd ${S}/scripts
+ sed -i -e 's/^make/make ${MAKEOPTS}/' build_qcad.sh
+ sed -i -e 's/^\.\/configure/.\/configure --host=${CHOST}/' build_qcad.sh
+ sh build_qcad.sh || die "build failed"
+}
+
+src_install () {
+ cd qcad
+ mv qcad qcad.bin
+ dobin qcad.bin
+ echo -e "#!/bin/sh\ncd /usr/share/${P}\nqcad.bin" > qcad
+ chmod ugo+rx qcad
+ dobin qcad
+ dodir /usr/share/${P}
+ cp -a patterns examples fonts scripts qm ${D}/usr/share/${P}
+ cd ..
+ dodoc README
+}
+