summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/time/time-1.1.1.ebuild')
-rw-r--r--dev-haskell/time/time-1.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/time/time-1.1.1.ebuild b/dev-haskell/time/time-1.1.1.ebuild
new file mode 100644
index 000000000000..b4fdd4ea7a4d
--- /dev/null
+++ b/dev-haskell/time/time-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/time/time-1.1.1.ebuild,v 1.1 2007/07/08 17:41:01 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+GHC_PV=6.6.1
+
+DESCRIPTION="A Haskell time library."
+HOMEPAGE="http://haskell.org/ghc/"
+SRC_URI="http://www.haskell.org/ghc/dist/${GHC_PV}/ghc-${GHC_PV}-src-extralibs.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.6"
+
+S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
+
+# Sadly Setup.hs in the ghc-6.6.1 extralibs was not tested with Cabal-1.1.6.x
+src_unpack() {
+ unpack "${A}"
+ sed -e "/type Hook/ s/UserHooks/Maybe UserHooks/" \
+ -e "/^runTestScript ::/ d" \
+ -e "s/maybeExit \\\$ //" \
+ -i ${S}/Setup.hs
+}