summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libredblack/libredblack-1.3.ebuild')
-rw-r--r--dev-libs/libredblack/libredblack-1.3.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/dev-libs/libredblack/libredblack-1.3.ebuild b/dev-libs/libredblack/libredblack-1.3.ebuild
index 64a0a9107fb0..f05c1f7a69df 100644
--- a/dev-libs/libredblack/libredblack-1.3.ebuild
+++ b/dev-libs/libredblack/libredblack-1.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libredblack/libredblack-1.3.ebuild,v 1.8 2007/07/02 14:59:53 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libredblack/libredblack-1.3.ebuild,v 1.9 2009/09/06 19:15:24 vostorga Exp $
+
+inherit eutils
DESCRIPTION="RedBlack Balanced Tree Searching and Sorting Library"
HOMEPAGE="http://libredblack.sourceforge.net/"
@@ -11,19 +13,26 @@ KEYWORDS="~x86 ~ppc"
SLOT="0"
IUSE=""
-DEPEND="virtual/libc"
+DEPEND=""
+RDEPEND="${DEPEND}"
#RESTRICT="mirror"
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-pep0263.patch
+}
+
src_compile() {
econf --libexecdir=/usr/lib || die "configure failure"
emake || die "compile failure"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
rm example*.o
- cp -pPR example* ${D}/usr/share/doc/${PF}
+ cp -pPR example* "${D}"/usr/share/doc/${PF}
}