summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlp5/camlp5-5.12.ebuild')
-rw-r--r--dev-ml/camlp5/camlp5-5.12.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ml/camlp5/camlp5-5.12.ebuild b/dev-ml/camlp5/camlp5-5.12.ebuild
deleted file mode 100644
index 4db979a1ef33..000000000000
--- a/dev-ml/camlp5/camlp5-5.12.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.12.ebuild,v 1.5 2009/08/09 16:18:08 nixnut Exp $
-
-EAPI="2"
-
-inherit multilib findlib eutils
-
-DESCRIPTION="A preprocessor-pretty-printer of ocaml"
-HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
-SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86 ~x86-fbsd"
-IUSE="doc +ocamlopt"
-
-DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- ./configure \
- -prefix /usr \
- -bindir /usr/bin \
- -libdir /usr/$(get_libdir)/ocaml \
- -mandir /usr/share/man || die "configure failed"
-}
-
-src_compile(){
- emake -j1 || die "emake failed"
- if use ocamlopt; then
- emake -j1 opt || die "Compiling native code programs failed"
- emake -j1 opt.opt || die "Compiling native code programs failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- # findlib support
- insinto "$(ocamlfind printconf destdir)/${PN}"
- doins etc/META || die "failed to install META file for findlib support"
-
- use doc && dohtml -r doc/*
-
- dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
-}