summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Sys-Virt/Sys-Virt-1.0.0.ebuild')
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-1.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Sys-Virt/Sys-Virt-1.0.0.ebuild b/dev-perl/Sys-Virt/Sys-Virt-1.0.0.ebuild
new file mode 100644
index 000000000000..fc5636cb3f17
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Sys-Virt/Sys-Virt-1.0.0.ebuild,v 1.1 2012/11/24 07:33:22 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=DANBERR
+MODULE_VERSION=1.0.0
+inherit perl-module
+
+DESCRIPTION="Sys::Virt provides an API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=app-emulation/libvirt-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+
+SRC_TEST="do"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}