summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/beaker/beaker-0.6.2.ebuild')
-rw-r--r--dev-python/beaker/beaker-0.6.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/beaker/beaker-0.6.2.ebuild b/dev-python/beaker/beaker-0.6.2.ebuild
new file mode 100644
index 000000000000..ef99c9c805e1
--- /dev/null
+++ b/dev-python/beaker/beaker-0.6.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beaker/beaker-0.6.2.ebuild,v 1.1 2007/02/27 23:55:19 dev-zero Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PN=Beaker
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A simple WSGI middleware to use the Myghty Container API"
+HOMEPAGE="http://beaker.groovie.org"
+SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/myghtyutils"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )
+ dev-python/setuptools"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/install_requires = \[.*\],/d' \
+ -e '/install_requires/, /],/d' \
+ setup.py || die "sed failed"
+}
+
+src_test() {
+ PYTHONPATH=. "${python}" setup.py nosetests || die "test failed"
+}