summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbus-python/dbus-python-0.82.4.ebuild')
-rw-r--r--dev-python/dbus-python/dbus-python-0.82.4.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/dbus-python/dbus-python-0.82.4.ebuild b/dev-python/dbus-python/dbus-python-0.82.4.ebuild
index db68029ec537..c952f6f490d6 100644
--- a/dev-python/dbus-python/dbus-python-0.82.4.ebuild
+++ b/dev-python/dbus-python/dbus-python-0.82.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.82.4.ebuild,v 1.11 2008/11/09 11:59:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dbus-python/dbus-python-0.82.4.ebuild,v 1.12 2009/01/18 18:59:43 eva Exp $
inherit python multilib
@@ -27,14 +27,13 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # don't run py-compile
- sed -i \
- -e '/if test -n "$$dlist"; then/,/else :; fi/d' \
- Makefile.in || die "sed in Makefile.in failed"
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
}
src_compile() {
- econf --docdir=/usr/share/doc/dbus-python-${PV} || die "econf failed"
+ econf --docdir=/usr/share/doc/dbus-python-${PV}
emake || die "emake failed"
}
@@ -44,6 +43,7 @@ src_install() {
pkg_postinst() {
python_version
+ python_need_rebuild
python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/dbus
}