summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycups/pycups-1.9.51.ebuild')
-rw-r--r--dev-python/pycups/pycups-1.9.51.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pycups/pycups-1.9.51.ebuild b/dev-python/pycups/pycups-1.9.51.ebuild
new file mode 100644
index 000000000000..89c0eb582e1c
--- /dev/null
+++ b/dev-python/pycups/pycups-1.9.51.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/pycups-1.9.51.ebuild,v 1.1 2010/06/28 16:31:42 reavertm Exp $
+
+EAPI="2"
+
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+inherit distutils flag-o-matic
+
+DESCRIPTION="Python bindings for the CUPS API"
+HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
+SRC_URI="http://cyberelk.net/tim/data/pycups/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="doc examples"
+
+RDEPEND="
+ >=net-print/cups-1.4.4
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc )
+"
+
+src_compile() {
+ append-cflags -DVERSION=\\\"${PV}\\\"
+ distutils_src_compile
+
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r html/ || die "installing html docs failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/"${P}"
+ doins -r examples/ || die "installing examples failed"
+ fi
+}