summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyparted/pyparted-1.6.9-r1.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-1.6.9-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyparted/pyparted-1.6.9-r1.ebuild b/dev-python/pyparted/pyparted-1.6.9-r1.ebuild
new file mode 100644
index 000000000000..821feaf56a6e
--- /dev/null
+++ b/dev-python/pyparted/pyparted-1.6.9-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-1.6.9-r1.ebuild,v 1.1 2005/04/04 22:57:38 gustavoz Exp $
+
+RH_EXTRAVERSION="3"
+
+inherit eutils rpm flag-o-matic
+
+DESCRIPTION="Python bindings for parted"
+HOMEPAGE="http://fedora.redhat.com"
+SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/${P}-${RH_EXTRAVERSION}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+# Needed to build...
+DEPEND=">=sys-apps/parted-1.6.9"
+
+src_unpack() {
+ rpm_src_unpack
+}
+
+src_compile() {
+ cd ${S}
+
+ # -fPIC needed for compilation on amd64, applied globally as only one shared
+ # lib is produced by this package.
+ append-flags -fPIC
+
+ # This is needed otherwise it won't build
+ # If anyone wants to figure out why... go ahead!
+ export LDFLAGS="-ldl"
+ econf || die
+ emake || die
+}
+
+src_install () {
+ einstall || die "Install failed!"
+ dodoc AUTHORS COPYING README ChangeLog
+}