summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-inline')
-rw-r--r--dev-ruby/ruby-inline/ChangeLog7
-rw-r--r--dev-ruby/ruby-inline/ruby-inline-3.9.0.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/ruby-inline/ChangeLog b/dev-ruby/ruby-inline/ChangeLog
index 7f76911f2468..8a572648abb3 100644
--- a/dev-ruby/ruby-inline/ChangeLog
+++ b/dev-ruby/ruby-inline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-inline
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ChangeLog,v 1.34 2011/02/17 07:04:56 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ChangeLog,v 1.35 2011/02/19 08:30:41 graaff Exp $
+
+*ruby-inline-3.9.0 (19 Feb 2011)
+
+ 19 Feb 2011; Hans de Graaff <graaff@gentoo.org> +ruby-inline-3.9.0.ebuild:
+ Version bump.
*ruby-inline-3.8.6-r1 (17 Feb 2011)
diff --git a/dev-ruby/ruby-inline/ruby-inline-3.9.0.ebuild b/dev-ruby/ruby-inline/ruby-inline-3.9.0.ebuild
new file mode 100644
index 000000000000..3b72a2e37616
--- /dev/null
+++ b/dev-ruby/ruby-inline/ruby-inline-3.9.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ruby-inline-3.9.0.ebuild,v 1.1 2011/02/19 08:30:41 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="RubyInline"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend dev-ruby/zentest
+
+ruby_add_bdepend "
+ doc? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ )
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # we have to patch the code so that it takes the RUBY_DESCRIPTION
+ # into consideration, to avoid loading Ruby-Enterprise (REE18)
+ # objects in MRI and vice-versa; we're a bit “greedier” since we
+ # will rebuild objects even when just switching versions, but
+ # it'll be better this way than being too conservatives.
+ epatch "${FILESDIR}/${PN}-3.8.4-gentoo.patch"
+
+ # Respect ruby's (and thus Gentoo's) LDFLAGS, and explicitly link
+ # against the ruby shared library to avoid confusion and potential
+ # crashes when later using the shared object.
+ epatch "${FILESDIR}/${PN}-3.8.4-ldflags.patch"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb || die
+}