summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/stella/stella-2.6.1.ebuild')
-rw-r--r--games-emulation/stella/stella-2.6.1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/games-emulation/stella/stella-2.6.1.ebuild b/games-emulation/stella/stella-2.6.1.ebuild
deleted file mode 100644
index 43af65fdadbe..000000000000
--- a/games-emulation/stella/stella-2.6.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-2.6.1.ebuild,v 1.3 2008/07/24 17:53:58 armin76 Exp $
-
-inherit eutils games
-
-DESCRIPTION="Stella Atari 2600 VCS Emulator"
-HOMEPAGE="http://stella.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE="opengl"
-
-DEPEND="media-libs/libsdl
- media-libs/libpng
- opengl? ( virtual/opengl )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
- sed -i \
- -e '/INSTALL/s/-s //' \
- -e '/STRIP/d' \
- -e "/icons/d" \
- -e '/INSTALL.*DOCDIR/d' \
- -e '/INSTALL.*\/applications/d' \
- Makefile \
- || die "sed failed"
-}
-
-src_compile() {
- # not an autoconf script
- ./configure \
- --prefix="/usr" \
- --bindir="${GAMES_BINDIR}" \
- --docdir="/usr/share/doc/${PF}" \
- --datadir="${GAMES_DATADIR}" \
- $(use_enable opengl gl) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- doicon src/common/stella.png
- make_desktop_entry stella Stella
- dohtml -r docs/*
- dodoc Announce.txt Changes.txt Copyright.txt README-GP2X.txt README-SDL.txt Readme.txt Todo.txt
- prepgamesdirs
-}