summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild')
-rw-r--r--games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild b/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild
new file mode 100644
index 000000000000..a30ec798ff13
--- /dev/null
+++ b/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-bonuspacks/unreal-tournament-bonuspacks-436.ebuild,v 1.1 2003/09/09 18:10:15 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Futuristic FPS (bonus packs)"
+HOMEPAGE="http://www.unrealtournament.com/"
+# UT has 4 official bonus packs ...
+# [UTBonusPack] -> loki put into app-games/unreal-tournament
+# [UTBonusPack2] -> loki put into app-games/unreal-tournament
+# [UTiNoxxPack] -> loki put into app-games/unreal-tournament
+# [UTBonusPack4] -> none of this is in app-games/unreal-tournament
+SRC_URI="http://fileserver.talkware.net/ut/bonuspacks/UTBonusPack4.zip
+ http://www.dices.de/dices/files/UTBonusPack4.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -alpha"
+IUSE="X"
+
+DEPEND="app-arch/unzip
+ || ( app-games/unreal-tournament app-games/unreal-tournament-goty )
+ app-games/umodpack"
+RDEPEND="X? ( virtual/x11 )"
+
+S=${WORKDIR}
+
+src_install() {
+ # unpack the UTBonusPack4 umod
+ umod -v -b `pwd` -x UTBonusPack4.umod || die "could not unpack UTBonusPack4.umod"
+
+ # move stuff around
+ rm UTBonusPack4.umod
+ mv system System
+ mv textures Textures
+
+ # install it all
+ local dir=${GAMES_PREFIX_OPT}/unreal-tournament
+ dodir ${dir}
+ mv * ${D}/${dir}/
+
+ prepgamesdirs
+}