summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kaddressbook/kaddressbook-4.8.2.ebuild')
-rw-r--r--kde-base/kaddressbook/kaddressbook-4.8.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-base/kaddressbook/kaddressbook-4.8.2.ebuild b/kde-base/kaddressbook/kaddressbook-4.8.2.ebuild
new file mode 100644
index 000000000000..d38f1aec000b
--- /dev/null
+++ b/kde-base/kaddressbook/kaddressbook-4.8.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-4.8.2.ebuild,v 1.1 2012/04/04 23:58:58 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+KDE_SCM="git"
+inherit kde4-meta
+
+DESCRIPTION="The KDE Address Book"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ >=dev-libs/grantlee-0.1.4
+ $(add_kdebase_dep kdelibs 'semantic-desktop')
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+# bug 393127
+
+KMEXTRA="
+ plugins/kaddressbook/
+ plugins/ktexteditor/
+"
+KMEXTRACTONLY="
+ akonadi_next/
+ calendarsupport/
+ libkleo/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+}