summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdegraphics/kdegraphics-3.4.0_beta2.ebuild')
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.4.0_beta2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/kde-base/kdegraphics/kdegraphics-3.4.0_beta2.ebuild b/kde-base/kdegraphics/kdegraphics-3.4.0_beta2.ebuild
new file mode 100644
index 000000000000..02a8ae159e0d
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.4.0_beta2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.4.0_beta2.ebuild,v 1.1 2005/02/09 16:18:45 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE graphics-related apps"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="gphoto2 imlib opengl povray scanner tetex"
+
+DEPEND="~kde-base/kdebase-${PV}
+ gphoto2? ( media-gfx/gphoto2 )
+ scanner? ( media-gfx/sane-backends )
+ dev-libs/fribidi
+ imlib? ( media-libs/imlib )
+ virtual/ghostscript
+ media-libs/tiff
+ povray? ( media-gfx/povray
+ virtual/opengl )"
+
+RDEPEND="${DEPEND}
+ app-text/xpdf
+ tetex? (
+ || ( >=app-text/tetex-2
+ app-text/ptex
+ app-text/cstetex
+ app-text/dvipdfm )
+ )"
+
+src_unpack() {
+ kde_src_unpack
+
+ epatch ${FILESDIR}/CAN-2005-0064_kde-3.4.patch
+}
+
+src_compile() {
+ use gphoto2 \
+ && myconf="$myconf --with-kamera \
+ --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2" \
+ || myconf="$myconf --without-kamera"
+
+ use scanner || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kooka libkscan"
+
+ use imlib \
+ && myconf="$myconf --with-imlib --with-imlib-config=/usr/bin" \
+ || myconf="$myconf --without-imlib"
+
+ kde_src_compile
+}