summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/krec/krec-3.5_alpha1.ebuild')
-rw-r--r--kde-base/krec/krec-3.5_alpha1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-base/krec/krec-3.5_alpha1.ebuild b/kde-base/krec/krec-3.5_alpha1.ebuild
new file mode 100644
index 000000000000..2c49f16c26f8
--- /dev/null
+++ b/kde-base/krec/krec-3.5_alpha1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/krec/krec-3.5_alpha1.ebuild,v 1.1 2005/09/07 12:40:27 flameeyes Exp $
+
+KMNAME=kdemultimedia
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE sound recorder"
+KEYWORDS="~amd64"
+IUSE="vorbis encode"
+OLDDEPEND="
+ ~kde-base/kdemultimedia-arts-$PV
+ vorbis? ( media-libs/libvorbis )
+ encode? ( media-sound/lame )"
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/kdemultimedia-arts)
+ vorbis? ( media-libs/libvorbis )
+ encode? ( media-sound/lame )"
+
+KMCOPYLIB="libartsgui_kde arts/gui/kde/
+ libartscontrolsupport arts/tools/"
+KMEXTRACTONLY="
+ arts/
+ kioslave/audiocd/configure.in.in"
+
+pkg_setup() {
+ if ! useq arts; then
+ eerror "${PN} needs the USE=\"arts\" enabled and also the kdelibs compiled with the USE=\"arts\" enabled"
+ die
+ fi
+}
+
+src_compile() {
+ use vorbis && myconf="$myconf --with-vorbis=/usr" || myconf="$myconf --without-vorbis"
+ use encode && myconf="$myconf --with-lame=/usr" || myconf="$myconf --without-lame"
+ kde-meta_src_compile
+}