summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pqiv/pqiv-0.6.1.ebuild')
-rw-r--r--media-gfx/pqiv/pqiv-0.6.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-gfx/pqiv/pqiv-0.6.1.ebuild b/media-gfx/pqiv/pqiv-0.6.1.ebuild
new file mode 100644
index 000000000000..28012022c233
--- /dev/null
+++ b/media-gfx/pqiv/pqiv-0.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pqiv/pqiv-0.6.1.ebuild,v 1.1 2007/10/25 17:49:09 drac Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Modern rewrite of Quick Image Viewer"
+HOMEPAGE="http://www.pberndt.com/Programme/Linux/pqiv"
+SRC_URI="http://www.pberndt.com/raw/Programme/Linux/${PN}/_download/${P}.tbz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.8"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake pqiv failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc README
+}