summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/qiv/files/fix_prefix.pl')
-rw-r--r--media-gfx/qiv/files/fix_prefix.pl21
1 files changed, 0 insertions, 21 deletions
diff --git a/media-gfx/qiv/files/fix_prefix.pl b/media-gfx/qiv/files/fix_prefix.pl
deleted file mode 100644
index 323fcff91121..000000000000
--- a/media-gfx/qiv/files/fix_prefix.pl
+++ /dev/null
@@ -1,21 +0,0 @@
-
-# this will hopefully be replaced by a leaner
-# sed method later by someone with a clue.
-#
-open MAKEFILE, "${ARGV[0]}/Makefile";
-open TMP, ">${ARGV[0]}/tmp";
-
-while ( <MAKEFILE> ) {
- last if $_ =~ /^PREFIX/;
- print TMP $_;
-}
-
-print TMP "PREFIX = ${ARGV[1]}\n";
-
-print TMP while <MAKEFILE>;
-
-close MAKEFILE;
-close TMP;
-
-system "cp ${ARGV[0]}/tmp ${ARGV[0]}/Makefile";
-unlink "${ARGV[0]}/tmp";