summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/metasploit/metasploit-2.3-r2.ebuild')
-rw-r--r--net-analyzer/metasploit/metasploit-2.3-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/metasploit/metasploit-2.3-r2.ebuild b/net-analyzer/metasploit/metasploit-2.3-r2.ebuild
new file mode 100644
index 000000000000..16f28dae7f17
--- /dev/null
+++ b/net-analyzer/metasploit/metasploit-2.3-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/metasploit/metasploit-2.3-r2.ebuild,v 1.1 2005/04/27 12:01:41 ka0ttic Exp $
+
+MY_P="${P/metasploit/framework}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="The Metasploit Framework is an advanced open-source platform for developing, testing, and using vulnerability exploit code."
+HOMEPAGE="http://www.metasploit.org/"
+SRC_URI="http://metasploit.com/tools/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/Net-SSLeay
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/TermReadKey"
+
+src_install() {
+ dodir /usr/lib/
+ dodir /usr/bin/
+
+ # should be as simple as copying everything into the target...
+ cp -a ${S} ${D}usr/lib/metasploit || die
+
+ # and creating symlinks in the /usr/bin dir
+ cd ${D}/usr/bin
+ ln -s ../lib/metasploit/msf* ./ || die
+ chown -R root:root ${D}
+
+ newinitd ${FILESDIR}/msfweb.initd msfweb || die "newinitd failed"
+ newconfd ${FILESDIR}/msfweb.confd msfweb || die "newconfd failed"
+}
+
+pkg_postinst() {
+ ewarn "You may wish to perform a metasploit update to get"
+ ewarn "the latest modules (e.g. run 'msfupdate -u')"
+}