summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall/iptables/iptables-1.2.9-r1.ebuild')
-rw-r--r--net-firewall/iptables/iptables-1.2.9-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-firewall/iptables/iptables-1.2.9-r1.ebuild b/net-firewall/iptables/iptables-1.2.9-r1.ebuild
index fb91c4fb1711..2ea8956d9d4e 100644
--- a/net-firewall/iptables/iptables-1.2.9-r1.ebuild
+++ b/net-firewall/iptables/iptables-1.2.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r1.ebuild,v 1.2 2004/04/28 05:05:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r1.ebuild,v 1.3 2004/05/10 14:07:04 aliz Exp $
inherit eutils flag-o-matic
@@ -19,6 +19,10 @@ DEPEND="virtual/linux-sources"
src_unpack() {
replace-flags -O0 -O2
+ if [ -z `get-flag O` ]; then
+ append-flags -O2
+ fi
+
unpack ${A} ; cd ${S}
epatch ${FILESDIR}/${PV}-files