summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/irssi/irssi-0.8.13-r1.ebuild')
-rw-r--r--net-irc/irssi/irssi-0.8.13-r1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/net-irc/irssi/irssi-0.8.13-r1.ebuild b/net-irc/irssi/irssi-0.8.13-r1.ebuild
deleted file mode 100644
index c38c13266a9a..000000000000
--- a/net-irc/irssi/irssi-0.8.13-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.13-r1.ebuild,v 1.6 2009/06/07 17:02:02 nixnut Exp $
-
-inherit perl-module
-
-DESCRIPTION="A modular textUI IRC client with IPv6 support"
-HOMEPAGE="http://irssi.org/"
-SRC_URI="http://irssi.org/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="ipv6 perl ssl socks5"
-
-RDEPEND="sys-libs/ncurses
- >=dev-libs/glib-2.2.1
- ssl? ( dev-libs/openssl )
- perl? ( dev-lang/perl )
- socks5? ( >=net-proxy/dante-1.1.18 )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9.0"
-RDEPEND="${RDEPEND}
- perl? ( !net-im/silc-client )
- !net-irc/irssi-svn"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-svn-5068.patch
-
- epunt_cxx
-}
-
-src_compile() {
- econf \
- --with-proxy \
- --with-ncurses \
- --with-perl-lib=vendor \
- $(use_with perl) \
- $(use_with socks5 socks) \
- $(use_enable ssl) \
- $(use_enable ipv6) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make \
- DESTDIR="${D}" \
- docdir=/usr/share/doc/${PF} \
- install || die "make install failed"
-
- use perl && fixlocalpod
-
- dodoc AUTHORS ChangeLog README TODO NEWS || die "dodoc failed"
-}