summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild')
-rw-r--r--net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild b/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild
new file mode 100644
index 000000000000..d2a9578c9f50
--- /dev/null
+++ b/net-mail/qmail-autoresponder/qmail-autoresponder-0.95.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Maintainer: Thilo Bangert <bangert@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+S=${WORKDIR}/${P}
+
+DEPEND="virtual/glibc"
+RDEPEND=">=net-mail/qmail-1.03-r7"
+
+DESCRIPTION="Rate-limited autoresponder for qmail."
+SRC_URI="http://untroubled.org/qmail-autoresponder/${P}.tar.gz"
+
+HOMEPAGE="http://untroubled.org/qmail-autoresponder/"
+
+src_compile() {
+ cd ${S}
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ emake || die
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe qmail-autoresponder
+ doman qmail-autoresponder.1
+}
+
+pkg_postinst() {
+
+ echo
+ einfo "Using qmail-autoresponder ..."
+ echo
+ einfo "Put \"|qmail-autoresponder MESSAGE_FILE DIRECTORY\" into your \".qmail\""
+ einfo "file before other delivery instructions. MESSAGE_FILE is a"
+ einfo "pre-formatted response, including headers, and DIRECTORY is the"
+ einfo "directory into which rate-limiting information will be stored. Any"
+ einfo "instance of "%S" in MESSAGE_FILE will be replaced with the original"
+ einfo "subject."
+ echo
+}