summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/pan/pan-0.14.2.ebuild')
-rw-r--r--net-news/pan/pan-0.14.2.ebuild32
1 files changed, 19 insertions, 13 deletions
diff --git a/net-news/pan/pan-0.14.2.ebuild b/net-news/pan/pan-0.14.2.ebuild
index 0bf0de326a9e..309099ed8ba7 100644
--- a/net-news/pan/pan-0.14.2.ebuild
+++ b/net-news/pan/pan-0.14.2.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.14.2.ebuild,v 1.11 2004/10/04 22:03:06 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.14.2.ebuild,v 1.12 2004/12/05 02:18:13 swegener Exp $
+
+inherit libtool
IUSE="nls spell"
DESCRIPTION="A newsreader for the Gnome2 desktop"
SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/SOURCE/${P}.tar.bz2"
-HOMEPAGE="http://pan.rebelbase.com"
+HOMEPAGE="http://pan.rebelbase.com/"
LICENSE="GPL-2"
KEYWORDS="x86 hppa ppc sparc amd64"
@@ -24,25 +26,29 @@ DEPEND="${RDEPEND}
export CONFIG_PROTECT_MASK="/etc/gconf"
-src_compile() {
- local myconf=""
-
+pkg_setup() {
# Likely that glibc might of been compiled with nls turned off.
# Warn people that Pan requires glibc to have nls support.
- if ! use nls; then
+ if ! use nls
+ then
ewarn "Pan requires glibc to be merged with 'nls' in your USE flags."
fi
+}
- use spell \
- && myconf="${myconf} --enable-gtkspell" \
- || myconf="${myconf} --disable-gtkspell"
- cd ${S} && libtoolize -c -f
- econf ${myconf} || die "Configure failure"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ elibtoolize || die "elibtoolize failed"
+}
+
+src_compile() {
+ econf $(use_enable spell gtkspell) || die "Configure failure"
emake || die "Compilation failure"
}
src_install() {
- einstall || die "Installation failed"
- dodoc ANNOUNCE AUTHORS ChangeLog COPYING CREDITS INSTALL NEWS README TODO
+ make install DESTDIR=${D} || die "Installation failed"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README TODO || die "dodoc failed"
+ dohtml ANNOUNCE.html docs/{pan-shortcuts,faq}.html || die "dodoc failed"
}