summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/biopython/biopython-1.30.ebuild')
-rw-r--r--sci-biology/biopython/biopython-1.30.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-biology/biopython/biopython-1.30.ebuild b/sci-biology/biopython/biopython-1.30.ebuild
new file mode 100644
index 000000000000..f3c6516bc240
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.30.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.30.ebuild,v 1.1 2004/12/23 22:16:34 ribosome Exp $
+
+inherit distutils
+
+IUSE=""
+
+DESCRIPTION="Biopython - python modules for computational molecular biology"
+SRC_URI="http://www.biopython.org/files/${P}.tar.gz"
+HOMEPAGE="http://www.biopython.org"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/egenix-mx-base-2.0.3
+ >=dev-python/numeric-19.0
+ >=dev-python/reportlab-1.11"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="Doc/* Doc/install/*.txt"
+ distutils_src_install
+
+ dohtml Doc/install/*.html
+ cp -r Doc/examples/ ${D}/usr/share/doc/${PF}/
+}