summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/yaboot/yaboot-1.3.17-r2.ebuild')
-rw-r--r--sys-boot/yaboot/yaboot-1.3.17-r2.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
index ad93a575bbc7..224b23f67270 100644
--- a/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.8 2015/05/17 04:27:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.17-r2.ebuild,v 1.9 2015/05/17 05:02:02 vapier Exp $
EAPI="5"
@@ -32,19 +32,16 @@ src_unpack() {
src_prepare() {
# No need to hardcode this path -- the compiler already knows to use it.
+ # Error only on real errors, for prom printing format compile failure.
sed -i \
-e 's:-I/usr/include::' \
+ -e 's:-Werror:-Wno-error:g' \
Makefile || die
# dual boot patch
epatch "${FILESDIR}/yabootconfig-1.3.13.patch"
epatch "${FILESDIR}/chrpfix.patch"
epatch "${FILESDIR}/${P}-nopiessp-gcc4.patch"
-
- # Error only on real errors, for prom printing format compile failure
- sed -i "s:-Werror:-Wno-error:g" Makefile
-
- # Stub out some functions that are not provided (and unneeded)
epatch "${FILESDIR}/${PN}-stubfuncs.patch"
# Fix the devspec path on newer kernels