summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-1.5d-r1.ebuild')
-rw-r--r--sys-devel/automake/automake-1.5d-r1.ebuild119
1 files changed, 119 insertions, 0 deletions
diff --git a/sys-devel/automake/automake-1.5d-r1.ebuild b/sys-devel/automake/automake-1.5d-r1.ebuild
new file mode 100644
index 000000000000..c4e440a3a19b
--- /dev/null
+++ b/sys-devel/automake/automake-1.5d-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5d-r1.ebuild,v 1.1 2002/03/26 00:46:36 azarah Exp $
+
+OLD_PV=1.4-p5
+OLD_P=${PN}-${OLD_PV}
+S=${WORKDIR}/${P}
+OLD_S=${WORKDIR}/${OLD_P}
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+SRC_URI="ftp://sources.redhat.com/pub/${PN}/${P}.tar.bz2
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/automake/automake.html"
+
+DEPEND="sys-devel/perl
+ >=sys-devel/autoconf-2.52-r1"
+
+
+src_compile() {
+
+ #
+ # ************ automake-1.6x ************
+ #
+
+ # stupid configure script goes and run autoconf in a subdir,
+ # so 'ac-wrapper.pl' do not detect that it should use
+ # autoconf-2.5x
+ export WANT_AUTOCONF_2_5=1
+
+ cd ${S}
+
+ cp automake.texi automake.texi.orig
+ sed -e "s:setfilename automake.info:setfilename automake-1.5.info:" \
+ automake.texi.orig >automake.texi
+
+ ./configure --prefix=/usr \
+ --datadir=/usr/share/${P} \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake ${MAKEOPTS} || die
+
+ unset WANT_AUTOCONF_2_5
+
+ #
+ # ************ automake-1.4-p5 ************
+ #
+ cd ${OLD_S}
+ ./configure --prefix=/usr \
+ --datadir=/usr/share/${OLD_P} \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake ${MAKEOPTS} || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ newexe ${FILESDIR}/am-wrapper.pl-1.5 am-wrapper.pl
+
+ #
+ # ************ automake-1.6x ************
+ #
+
+ cd ${S}
+ make DESTDIR=${D} \
+ datadir=/usr/share/${P} \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x}-${PV} ${D}/usr/bin/${x}-1.5x
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo automake-1.5.info*
+
+ docinto ${PF}/${PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.4-p5 ************
+ #
+
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ datadir=${D}/usr/share/${OLD_P} \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-1.4
+ dosym ../lib/${PN}/am-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${PF}/${OLD_PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in automake aclocal
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+