summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/dosfstools/dosfstools-3.0.10.ebuild')
-rw-r--r--sys-fs/dosfstools/dosfstools-3.0.10.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/dosfstools/dosfstools-3.0.10.ebuild b/sys-fs/dosfstools/dosfstools-3.0.10.ebuild
new file mode 100644
index 000000000000..78e9189d74a9
--- /dev/null
+++ b/sys-fs/dosfstools/dosfstools-3.0.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/dosfstools-3.0.10.ebuild,v 1.1 2010/09/20 02:06:08 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="DOS filesystem tools - provides mkdosfs, mkfs.msdos, mkfs.vfat"
+HOMEPAGE="http://www.daniel-baumann.ch/software/dosfstools/"
+SRC_URI="http://www.daniel-baumann.ch/software/dosfstools/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+RESTRICT="test" # there is no test target #239071
+
+src_prepare() {
+ sed -i \
+ -e '/^PREFIX/s:/local::' \
+ -e '/^OPTFLAGS/s:=.*:=:' \
+ Makefile || die "sed Makefile"
+ append-lfs-flags
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodir /sbin
+ mv "${D}"/usr/sbin/*fsck* "${D}"/sbin/ || die
+ mv "${D}"/usr/share/doc/{${PN},${PF}} || die
+ prepalldocs
+}