summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/htop/htop-0.6.ebuild')
-rw-r--r--sys-process/htop/htop-0.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-process/htop/htop-0.6.ebuild b/sys-process/htop/htop-0.6.ebuild
new file mode 100644
index 000000000000..72ca43a21e4c
--- /dev/null
+++ b/sys-process/htop/htop-0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.6.ebuild,v 1.1 2005/12/28 22:50:21 wschlich Exp $
+
+inherit debug flag-o-matic
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+DEPEND="sys-libs/ncurses"
+
+src_compile() {
+ useq debug && append-flags -O -ggdb -DDEBUG
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO
+}