summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellmms/files/gkrellmms-2.1.22-audacious.patch')
-rw-r--r--x11-plugins/gkrellmms/files/gkrellmms-2.1.22-audacious.patch367
1 files changed, 367 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmms/files/gkrellmms-2.1.22-audacious.patch b/x11-plugins/gkrellmms/files/gkrellmms-2.1.22-audacious.patch
new file mode 100644
index 000000000000..e7a4a6c55a59
--- /dev/null
+++ b/x11-plugins/gkrellmms/files/gkrellmms-2.1.22-audacious.patch
@@ -0,0 +1,367 @@
+diff -aur ../gkrellmms/Makefile ./Makefile
+--- ../gkrellmms/Makefile 2005-01-21 18:02:17.000000000 +0100
++++ ./Makefile 2006-10-24 23:05:48.000000000 +0200
+@@ -12,9 +12,14 @@
+ XMMS_INCLUDE ?= `pkg-config bmp --cflags`
+ XMMS_LIB ?= `pkg-config bmp --libs`
+ else
++ifdef USE_AUDACIOUS
++ XMMS_INCLUDE ?= `pkg-config audacious --cflags`
++ XMMS_LIB ?= `pkg-config audacious --libs`
++else
+ XMMS_INCLUDE ?= `xmms-config --cflags`
+ XMMS_LIB ?= `xmms-config --libs`
+ endif
++endif
+
+ PLUGIN_DIR ?= /usr/local/lib/gkrellm2/plugins
+
+@@ -25,6 +30,9 @@
+ ifdef USE_BMP
+ FLAGS += -DUSE_BMP
+ endif
++ifdef USE_AUDACIOUS
++ FLAGS += -DUSE_AUDACIOUS
++endif
+
+ LOCALEDIR ?= /usr/share/locale
+ ifeq ($(enable_nls),1)
+diff -aur ../gkrellmms/gkrellmms.c ./gkrellmms.c
+--- ../gkrellmms/gkrellmms.c 2005-01-21 18:02:17.000000000 +0100
++++ ./gkrellmms.c 2006-10-24 23:49:58.000000000 +0200
+@@ -860,7 +860,13 @@
+
+ if (scrolling_tooltip == NULL) {
+ scrolling_tooltip = gtk_tooltips_new();
++#ifdef USE_AUDACIOUS
++ scrolling_tooltip_text = g_strdup("audacious");
++#elif USE_BMP
++ scrolling_tooltip_text = g_strdup("bmp");
++#else
+ scrolling_tooltip_text = g_strdup("xmms");
++#endif
+ gtk_tooltips_set_tip(scrolling_tooltip, scroll_panel->drawing_area,
+ scrolling_tooltip_text, NULL);
+ gtk_tooltips_set_delay(scrolling_tooltip, 750);
+@@ -1033,13 +1039,21 @@
+
+ playlist_dir = g_strdup(gkrellm_homedir());
+ files_directory = g_strdup("/");
++#ifdef USE_BMP
++ gkrellmms_label = g_strdup("bmp");
++#elif USE_AUDACIOUS
++ gkrellmms_label = g_strdup("audacious");
++#else
+ gkrellmms_label = g_strdup("xmms");
++#endif
+ xmms_session = 0;
+ scroll_enable = TRUE;
+ scroll_separator = g_strdup(SCROLL_SEPARATOR);
+ draw_time = 1;
+ #ifdef USE_BMP
+ xmms_exec_command = g_strdup("beep-media-player");
++#elif USE_AUDACIOUS
++ xmms_exec_command = g_strdup("audacious");
+ #else
+ xmms_exec_command = g_strdup("xmms");
+ #endif
+diff -aur ../gkrellmms/gkrellmms.h ./gkrellmms.h
+--- ../gkrellmms/gkrellmms.h 2005-01-21 18:02:17.000000000 +0100
++++ ./gkrellmms.h 2006-10-24 23:49:09.000000000 +0200
+@@ -27,6 +27,8 @@
+
+ #ifdef USE_BMP
+ #include <bmp/beepctrl.h>
++#elif USE_AUDACIOUS
++#include <audacious/beepctrl.h>
+ #else
+ #include <xmms/xmmsctrl.h>
+ #endif
+diff -aur ../gkrellmms/options.c ./options.c
+--- ../gkrellmms/options.c 2005-01-21 18:02:17.000000000 +0100
++++ ./options.c 2006-10-24 23:57:47.000000000 +0200
+@@ -44,6 +44,15 @@
+ static gint time_fmt_thing;
+ static gint always_load_thing;
+
++#ifdef USE_BMP
++ #define PROG_NAME "BMP"
++#elif USE_AUDACIOUS
++ #define PROG_NAME "Audacious"
++#else
++ #define PROG_NAME "XMMS"
++#endif
++
++
+ void toggles_func (GtkWidget *w, gpointer what)
+ {
+ gint type;
+@@ -178,28 +187,28 @@
+ {N_("/Toggles.../Always on top on"), NULL, aot_func, ON, "<Item>"},
+ {N_("/Toggles.../Always on top off"), NULL, aot_func, OFF, "<Item>"},
+ {"/-", NULL, NULL, 0, "<Separator>"},
+- {"/Xmms...", NULL, NULL, 0, "<Branch>"},
+- {N_("/Xmms.../Previous"), NULL, toggles_func, gkrellmms_prev, "<Item>"},
+- {N_("/Xmms.../Play"), NULL, toggles_func, gkrellmms_play, "<Item>"},
+- {N_("/Xmms.../Pause"), NULL, toggles_func, gkrellmms_paus, "<Item>"},
+- {N_("/Xmms.../Stop"), NULL, toggles_func, gkrellmms_stop, "<Item>"},
+- {N_("/Xmms.../Next"), NULL, toggles_func, gkrellmms_next, "<Item>"},
++ {"/"PROG_NAME"...", NULL, NULL, 0, "<Branch>"},
++ {N_("/"PROG_NAME".../Previous"), NULL, toggles_func, gkrellmms_prev, "<Item>"},
++ {N_("/"PROG_NAME".../Play"), NULL, toggles_func, gkrellmms_play, "<Item>"},
++ {N_("/"PROG_NAME".../Pause"), NULL, toggles_func, gkrellmms_paus, "<Item>"},
++ {N_("/"PROG_NAME".../Stop"), NULL, toggles_func, gkrellmms_stop, "<Item>"},
++ {N_("/"PROG_NAME".../Next"), NULL, toggles_func, gkrellmms_next, "<Item>"},
+ {"/-", NULL, NULL, 0, "<Separator>"},
+ {N_("/Playlist Editor"), NULL, open_playlist_cb, 0, "<Item>"},
+ {N_("/GKrellMMS Options"), NULL, open_options_cb, 0, "<Item>"},
+ {"/-", NULL, NULL, 0, "<Separator>"},
+ {N_("/Open file(s)"), NULL, toggles_func, gkrellmms_eject, "<Item>"},
+ {N_("/Open Playlist"), NULL, load_playlist_cb, 0, "<Item>"},
+- {N_("/XMMS Prefs"), NULL, toggles_func, gkrellmms_prefs, "<Item>"},
++ {N_("/"PROG_NAME" Prefs"), NULL, toggles_func, gkrellmms_prefs, "<Item>"},
+ {"/-", NULL, NULL, 0, "<Separator>"},
+- {N_("/Quit XMMS"), NULL, quit_func, 0, "<Item>"},
++ {N_("/Quit "PROG_NAME), NULL, quit_func, 0, "<Item>"},
+ {"/-", NULL, NULL, 0, "<Separator>"},
+ };
+
+ static GtkItemFactoryEntry gkrellmms_factory_norun[] =
+ {
+ {"/-", NULL, NULL, 0, "<Separator>"},
+- {N_("/Launch XMMS"), NULL, start_func, 0, "<Item>"},
++ {N_("/Launch "PROG_NAME), NULL, start_func, 0, "<Item>"},
+ {"/-", NULL, NULL, 0, "<Separator>"},
+ };
+
+@@ -423,19 +432,19 @@
+ gint i;
+ static gchar *gkrellmms_help_text[] =
+ {
+- N_("GKrellMMS is a GKrellM XMMS-plugin which allows you to control \n" \
+- "XMMS from within GKrellM. It features some cool things, such as: \n" \
++ N_("GKrellMMS is a GKrellM "PROG_NAME"-plugin which allows you to control \n" \
++ PROG_NAME" from within GKrellM. It features some cool things, such as: \n" \
+ "\n" \
+ "- A scrolling title. \n" \
+ "- A Krell which indicates where you are in a song. \n" \
+- "- Themeable buttons for controlling XMMS. \n" \
++ "- Themeable buttons for controlling "PROG_NAME". \n" \
+ "- A playlist editor. \n" \
+- "- A gtk-popup-menu with misc. XMMS-functions. \n" \
++ "- A gtk-popup-menu with misc. "PROG_NAME"-functions. \n" \
+ "\n"),
+
+ N_("<b>How to use GKrellMMS: \n"),
+ N_("\n" \
+- "You can do some cool stuff with the XMMS-Krell, by using your mouse. \n" \
++ "You can do some cool stuff with the "PROG_NAME"-Krell, by using your mouse. \n" \
+ "\n"),
+
+ N_("<b>Mouse actions: \n" \
+@@ -443,8 +452,8 @@
+ N_("Jump through song. \n"),
+
+ N_("<b>\tMiddle mouse-button: "),
+- N_("Pause/stop/play XMMS (configurable), \n" \
+- "\t or launch XMMS if it's not running. \n"),
++ N_("Pause/stop/play "PROG_NAME" (configurable), \n" \
++ "\t or launch "PROG_NAME" if it's not running. \n"),
+
+ N_("<b>\tRight mouse-button: "),
+ N_("Popup-menu. \n" \
+@@ -453,16 +462,16 @@
+ "\n"),
+
+ N_("<b>\tConstant red: "),
+- N_("XMMS is turned off. \n"),
++ N_(PROG_NAME" is turned off. \n"),
+
+ N_("<b>\tConstant green: "),
+- N_("XMMS is playing. \n"),
++ N_(PROG_NAME" is playing. \n"),
+
+ N_("<b>\tRed, blinking green: "),
+- N_("XMMS is stopped. \n"),
++ N_(PROG_NAME" is stopped. \n"),
+
+ N_("<b>\tGreen, blinking red: "),
+- N_("XMMS is paused. \n" \
++ N_(PROG_NAME" is paused. \n" \
+ "\n"),
+
+ N_("<b>Configurabilities:\n"),
+@@ -473,15 +482,15 @@
+
+ N_("<b>Configs tab: \n" \
+ "\n" \
+- "\tXMMS Executable: \n"),
++ "\t"PROG_NAME" Executable: \n"),
+
+- N_("\tHow the XMMS-executable (+ eventually path) \n" \
++ N_("\tHow the "PROG_NAME"-executable (+ eventually path) \n" \
+ "\tis called on your computer. Default is xmms\n" \
+ "\n"),
+
+ N_("<b>\tFiles Directory: \n"),
+ N_("\tThe directory where your mp3's/xm's/whatever \n" \
+- "\tare stored in. When starting XMMS from GKrellM, it will go to this \n" \
++ "\tare stored in. When starting "PROG_NAME" from GKrellM, it will go to this \n" \
+ "\tdirectory when ejecting. \n" \
+ "\n"),
+
+@@ -490,7 +499,7 @@
+ "\n"),
+
+ N_("<b>\tKrell label: \n"),
+- N_("\tThe text-label you want in the krell when xmms isn't running/playing. \n" \
++ N_("\tThe text-label you want in the krell when "PROG_NAME" isn't running/playing. \n" \
+ "\n"),
+
+ N_("<b>\tScroll separator: \n"),
+@@ -498,9 +507,9 @@
+ "\tIt defaults to ' *** ' (that's 3 spaces, 3 *'s and 3 spaces). \n" \
+ "\n"),
+
+- N_("<b>\tXMMS Session to use: \n"),
+- N_("\tThe XMMS-session you want to use with GKrellMMS. \n" \
+- "\tUse 0 if you only have 1 XMMS running. \n" \
++ N_("<b>\t"PROG_NAME" Session to use: \n"),
++ N_("\tThe "PROG_NAME"-session you want to use with GKrellMMS. \n" \
++ "\tUse 0 if you only have 1 "PROG_NAME" running. \n" \
+ "\n"),
+
+ N_("<b>Toggles tab: \n" \
+@@ -510,23 +519,23 @@
+ N_("\tDraw a minus (-) before the remaining time, when you have \n" \
+ "\tthe output-time displaying remaining time. \n\n"),
+
+- N_("<b>\tXMMS Auto Launch: \n"),
+- N_("\tAuto launch XMMS when starting GKrellMMS. \n" \
++ N_("<b>\t"PROG_NAME" Auto Launch: \n"),
++ N_("\tAuto launch "PROG_NAME" when starting GKrellMMS. \n" \
+ "\n"),
+
+ N_("<b>\tAuto Mainwindow Close: \n"),
+- N_("\tAutomatically close the XMMS-mainwindow \n" \
+- "\twhen GKrellMMS starts, and XMMS is already running, or when \n" \
+- "\tlaunching XMMS while GKrellMMS runs. This option also enables the \n" \
++ N_("\tAutomatically close the "PROG_NAME"-mainwindow \n" \
++ "\twhen GKrellMMS starts, and "PROG_NAME" is already running, or when \n" \
++ "\tlaunching "PROG_NAME" while GKrellMMS runs. This option also enables the \n" \
+ "\tmainwindow back when you quit gkrellm (some people really do). \n" \
+ "\n"),
+
+- N_("<b>\tAuto hide all XMMS windows: \n"),
+- N_("\tAutomatically hide all XMMS windows when GKrellMMS starts. \n" \
++ N_("<b>\tAuto hide all "PROG_NAME" windows: \n"),
++ N_("\tAutomatically hide all "PROG_NAME" windows when GKrellMMS starts. \n" \
+ "\n"),
+
+ N_("<b>\tAuto start playing: \n"),
+- N_("\tAutomatically start playing when launching XMMS. \n\n"),
++ N_("\tAutomatically start playing when launching "PROG_NAME". \n\n"),
+
+ N_("<b>\tEnable scrolling title: \n"),
+ N_("\tEnable/disable the scrolling title-panel. \n" \
+@@ -537,13 +546,13 @@
+ "\tEject opens: \n"),
+
+ N_("\tCheck whether the eject-button on the button-bar opens a \n" \
+- "\tplaylist or an other XMMS-file. \n" \
++ "\tplaylist or an other "PROG_NAME"-file. \n" \
+ "\n"),
+
+ N_("<b>\tMMB on krell click: \n"),
+ N_("\tCheck whether GKrellMMS should pause/continue or \n" \
+ "\tstop/play the current song on a MMB-click on the krell. MMB Click will \n" \
+- "\talways start playing the song if XMMS isn't playing. \n" \
++ "\talways start playing the song if "PROG_NAME" isn't playing. \n" \
+ "\n"),
+
+ N_("<b>\tLoad file-info: \n"),
+@@ -553,7 +562,7 @@
+ "\tplaylist editor, or are playing on a slow network/cdrom. \n\n"),
+
+ N_("<b>\tDraw in time bar: \n"),
+- N_("\tCheck whether to draw the output time or 'xmms' in \n" \
++ N_("\tCheck whether to draw the output time or '"PROG_NAME"' in \n" \
+ "\tthe time-krell panel. \n" \
+ "\n"),
+
+@@ -577,7 +586,7 @@
+ hbox = gtk_hbox_new(FALSE, 5);
+
+ zbox = gtk_vbox_new(FALSE, 0);
+- label = gtk_label_new(_("XMMS Executable:"));
++ label = gtk_label_new(_(PROG_NAME" Executable:"));
+ gtk_box_pack_start(GTK_BOX(zbox), label, TRUE, FALSE, 0);
+ label = gtk_label_new(_("Files Directory:"));
+ gtk_box_pack_start(GTK_BOX(zbox), label, TRUE, FALSE, 0);
+@@ -625,7 +634,7 @@
+ gtk_spin_button_set_digits(GTK_SPIN_BUTTON(session_entry), (guint) 0);
+ gtk_spin_button_set_value(GTK_SPIN_BUTTON(session_entry), xmms_session);
+ gtk_box_pack_start(GTK_BOX(hbox), session_entry, FALSE, FALSE, 0);
+- label = gtk_label_new(_("XMMS Session to use"));
++ label = gtk_label_new(_(PROG_NAME" Session to use"));
+ gtk_box_pack_start(GTK_BOX(hbox), label, FALSE, FALSE, 0);
+ gtk_container_add(GTK_CONTAINER(vbox), hbox);
+
+@@ -644,19 +653,19 @@
+ gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(draw_minus_entry), draw_minus);
+ gtk_container_add(GTK_CONTAINER(vbox), draw_minus_entry);
+
+- xmms_start_entry = gtk_check_button_new_with_label(_("Auto launch XMMS on GKrellMMS startup"));
++ xmms_start_entry = gtk_check_button_new_with_label(_("Auto launch "PROG_NAME" on GKrellMMS startup"));
+ gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(xmms_start_entry), xmms_autostart);
+ gtk_container_add(GTK_CONTAINER(vbox), xmms_start_entry);
+
+- main_close_entry = gtk_check_button_new_with_label(_("Auto close (and open) XMMS Mainwin"));
++ main_close_entry = gtk_check_button_new_with_label(_("Auto close (and open) "PROG_NAME" Mainwin"));
+ gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(main_close_entry), auto_main_close);
+ gtk_container_add(GTK_CONTAINER(vbox), main_close_entry);
+
+- hide_all_entry = gtk_check_button_new_with_label(_("Auto hide all XMMS windows on XMMS startup"));
++ hide_all_entry = gtk_check_button_new_with_label(_("Auto hide all "PROG_NAME" windows on "PROG_NAME" startup"));
+ gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(hide_all_entry), auto_hide_all);
+ gtk_container_add(GTK_CONTAINER(vbox), hide_all_entry);
+
+- auto_play_entry = gtk_check_button_new_with_label(_("Auto start playing on XMMS launch"));
++ auto_play_entry = gtk_check_button_new_with_label(_("Auto start playing on "PROG_NAME" launch"));
+ gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(auto_play_entry), auto_play_start);
+ gtk_container_add(GTK_CONTAINER(vbox), auto_play_entry);
+
+@@ -720,7 +729,7 @@
+ gtk_signal_connect(GTK_OBJECT(time_draw_entry), "pressed",
+ (GtkSignalFunc) time_type_set, GINT_TO_POINTER(1));
+
+- time_draw_entry = gtk_radio_button_new_with_label(time_draw_group, _("XMMS-text"));
++ time_draw_entry = gtk_radio_button_new_with_label(time_draw_group, _(PROG_NAME"-text"));
+ gtk_box_pack_start(GTK_BOX(zbox), time_draw_entry, FALSE, FALSE, 0);
+ gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(time_draw_entry), !draw_time);
+ gtk_signal_connect(GTK_OBJECT(time_draw_entry), "pressed",
+@@ -840,10 +849,11 @@
+ /* About */
+ gkrellmms_info_text = g_strdup_printf(
+ _("GKrellMMS %d.%d.%d\n" \
+- "GKrellM XMMS Plugin\n" \
++ "GKrellM XMMS/BMP/Audacious Plugin\n" \
+ "\n" \
+ "Copyright (C) 2000-2002 Sander Klein Lebbink <sander@cerberus.demon.nl>\n"\
+ "Current Maintainer: Sjoerd Simons <sjoerd@luon.net>\n" \
++ "Audacious Patch: Sascha Hlusiak <mail@saschahlusiak.de>\n" \
+ "http://gkrellm.luon.net/\n" \
+ "\n" \
+ "Released under the GNU Public License\n"),
+diff -aur ../gkrellmms/playlist.h ./playlist.h
+--- ../gkrellmms/playlist.h 2005-01-21 18:02:17.000000000 +0100
++++ ./playlist.h 2006-10-24 23:49:32.000000000 +0200
+@@ -26,6 +26,8 @@
+
+ #ifdef USE_BMP
+ #include <bmp/beepctrl.h>
++#elif USE_AUDACIOUS
++#include <audacious/beepctrl.h>
+ #else
+ #include <xmms/xmmsctrl.h>
+ #endif