summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmbio/wmbio-1.02.ebuild')
-rw-r--r--x11-plugins/wmbio/wmbio-1.02.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/x11-plugins/wmbio/wmbio-1.02.ebuild b/x11-plugins/wmbio/wmbio-1.02.ebuild
index 64a2c8af34b7..77a62dd287ee 100644
--- a/x11-plugins/wmbio/wmbio-1.02.ebuild
+++ b/x11-plugins/wmbio/wmbio-1.02.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbio/wmbio-1.02.ebuild,v 1.10 2008/11/25 23:33:51 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbio/wmbio-1.02.ebuild,v 1.11 2010/02/09 15:00:21 yngwin Exp $
+EAPI=2
inherit eutils
-DESCRIPTION="a Window Maker applet that shows your biorhythm"
+DESCRIPTION="A Window Maker applet that shows your biorhythm"
SRC_URI="http://wmbio.sourceforge.net/${P}.tar.gz"
HOMEPAGE="http://wmbio.sourceforge.net/"
@@ -21,18 +22,16 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
# Honour Gentoo CFLAGS
epatch "${FILESDIR}"/${PN}-Makefile.patch
}
src_compile() {
- emake || die "emake failed."
+ emake || die "emake failed"
}
src_install () {
- dobin wmbio || die "dobin failed."
- dodoc ../{AUTHORS,ChangeLog,NEWS,README}
+ dobin wmbio || die "dobin failed"
+ dodoc ../{AUTHORS,Changelog,NEWS,README} || die
}