summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/clusterssh/clusterssh-3.18.1-r1.ebuild')
-rw-r--r--x11-terms/clusterssh/clusterssh-3.18.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-terms/clusterssh/clusterssh-3.18.1-r1.ebuild b/x11-terms/clusterssh/clusterssh-3.18.1-r1.ebuild
new file mode 100644
index 000000000000..737f167dd96f
--- /dev/null
+++ b/x11-terms/clusterssh/clusterssh-3.18.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/clusterssh/clusterssh-3.18.1-r1.ebuild,v 1.1 2006/08/27 10:04:08 tantive Exp $
+
+DESCRIPTION="Concurrent Multi-Server Terminal Access."
+HOMEPAGE="http://clusterssh.sourceforge.net"
+SRC_URI="mirror://sourceforge/clusterssh/clusterssh-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.6.1
+ dev-perl/perl-tk
+ dev-perl/Config-Simple
+ dev-perl/X11-Protocol
+ x11-apps/xlsfonts"
+
+src_compile() {
+ # Gentoo perl ebuilds remove podchecker
+ if grep -v podchecker "${S}"/src/Makefile.in \
+ > "${S}"/src/Makefile.in.new; then
+ mv "${S}"/src/Makefile.in.new "${S}"/src/Makefile.in
+ else
+ die "Makefile.in update failed"
+ fi
+
+ econf || die "configuration failed"
+ emake || die "compiling failed"
+}
+
+src_install() {
+ cd "${S}"
+ dodoc AUTHORS COPYING INSTALL NEWS README THANKS
+ dobin src/cssh
+ doman src/cssh.1
+}
+
+pkg_postinst() {
+ elog "IMPORTANT:"
+ elog "If you use a term program other than xterm, you will most likely see
+ '-xrm' errors."
+ elog "To fix, do the following:"
+ elog " echo terminal_allow_send_events= >> ~/.csshrc"
+}