summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/fvwm/fvwm-2.5.30.ebuild')
-rw-r--r--x11-wm/fvwm/fvwm-2.5.30.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/x11-wm/fvwm/fvwm-2.5.30.ebuild b/x11-wm/fvwm/fvwm-2.5.30.ebuild
index 1092f3f17f77..b6280e54c6dc 100644
--- a/x11-wm/fvwm/fvwm-2.5.30.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.30.ebuild,v 1.1 2010/05/14 19:53:55 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.30.ebuild,v 1.2 2010/05/14 22:59:01 darkside Exp $
EAPI=2
@@ -103,11 +103,12 @@ src_configure() {
$(use_with stroke stroke-library) \
$(use_enable svg rsvg) \
$(use_enable truetype xft) \
- $(use_enable xinerama)
+ $(use_enable xinerama) \
+ --docdir="/usr/share/doc/${P}"
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${P}" install || die
# These are always removed, because gentoo doesn't have anymore
# a dev-perl/gtk-perl package, so, these modules are pointless.
@@ -149,9 +150,6 @@ src_install() {
echo "/usr/bin/fvwm" > "${D}/etc/X11/Sessions/${PN}" || die
fperms a+x /etc/X11/Sessions/${PN} || die
- # Move docs.
- mv "${D}"/usr/share/doc/{${PN},${P}}
-
dodoc AUTHORS ChangeLog NEWS README \
docs/{ANNOUNCE,BUGS,COMMANDS,CONVENTIONS} \
docs/{DEVELOPERS,error_codes,FAQ,TODO,fvwm.lsm}