aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Donofrio <justin026@protonmail.com>2024-07-12 12:05:03 -0400
committerJustin Donofrio <justin026@protonmail.com>2024-07-12 12:05:03 -0400
commit498e0a775434ce04aaeab984b4ce94ea2a4219b3 (patch)
tree2a3dd3245bbba05351a3d96c53b4255e8db25dee
parentnet-im/whatsapp-for-linux: add 1.6.4 (diff)
downloadguru-498e0a775434ce04aaeab984b4ce94ea2a4219b3.tar.gz
guru-498e0a775434ce04aaeab984b4ce94ea2a4219b3.tar.bz2
guru-498e0a775434ce04aaeab984b4ce94ea2a4219b3.zip
www-client/mullvad-browser-bin: add 13.5.1
Signed-off-by: Justin Donofrio <justin026@protonmail.com>
-rw-r--r--www-client/mullvad-browser-bin/Manifest1
-rw-r--r--www-client/mullvad-browser-bin/mullvad-browser-bin-13.5.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/www-client/mullvad-browser-bin/Manifest b/www-client/mullvad-browser-bin/Manifest
index aa0b0089b..3bd587714 100644
--- a/www-client/mullvad-browser-bin/Manifest
+++ b/www-client/mullvad-browser-bin/Manifest
@@ -1 +1,2 @@
+DIST mullvad-browser-linux-x86_64-13.5.1.tar.xz 103318368 BLAKE2B c9f4c1cfa951561d16368c4728ec95456076519b4270f4645b16156830963e374e9e2997909b18b6366877d8898bbe5de15b61119a1c6a993fdb0e16a02f20f5 SHA512 088465811c25639c507a023b4c1abf04ac5ae63ea066a6fc8f6504057ed9b7643895e0e376a8ff076a319b0e295e90dd2004267cc5388f85f094ecb08890ab45
DIST mullvad-browser-linux-x86_64-13.5.tar.xz 103263340 BLAKE2B a66e20e75152e6d03b4eff8b5580418fb11587700bb5e16036f9bcb2c094cb0fe531653ef1daf64b1bf5841b25c3bf2378b85aae9b4ccb88287896cd054842ee SHA512 8dfd65460852f1be2906d8e87e3b45589534e79213477ae5ae51b16e170fa24b1ea0ba1866771b625fbd3fc80311310b56abd493e5e3799bbaa9031654574401
diff --git a/www-client/mullvad-browser-bin/mullvad-browser-bin-13.5.1.ebuild b/www-client/mullvad-browser-bin/mullvad-browser-bin-13.5.1.ebuild
new file mode 100644
index 000000000..ebe737ca0
--- /dev/null
+++ b/www-client/mullvad-browser-bin/mullvad-browser-bin-13.5.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="The Mullvad Browser is developed to minimize tracking and fingerprinting."
+HOMEPAGE="https://github.com/mullvad/mullvad-browser https://mullvad.net/"
+SRC_URI="https://github.com/mullvad/mullvad-browser/releases/download/${PV}/mullvad-browser-linux-x86_64-${PV}.tar.xz"
+
+S="${WORKDIR}"
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+IUSE="wayland +X"
+
+RESTRICT="bindist mirror test strip"
+
+RDEPEND="
+ app-accessibility/at-spi2-core
+ app-misc/mime-types
+ app-shells/bash
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ gui-libs/gtk
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-video/ffmpeg
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-themes/hicolor-icon-theme
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXtst
+ wayland? (
+ sys-apps/xdg-desktop-portal
+ )"
+
+QA_PREBUILT="*"
+
+src_install() {
+ # Install profiles to home dir
+ touch "${S}"/mullvad-browser/Browser/is-packaged-app
+
+ # Fix desktop file vars
+ sed -i "s|Name=.*|Name=Mullvad Browser|g" "${S}"/mullvad-browser/start-mullvad-browser.desktop
+ sed -i "s|Exec=.*|Exec=/opt/mullvad-browser/Browser/start-mullvad-browser --detach|g" "${S}"/mullvad-browser/start-mullvad-browser.desktop
+ sed -i "s|Icon=.*|Icon=mullvad-browser|g" "${S}"/mullvad-browser/start-mullvad-browser.desktop
+
+ # Install shim for X11. Browser doesn't seem to launch without it, see upstream issue:
+ # https://gitlab.torproject.org/tpo/applications/tor-browser-build/-/issues/40565
+ #
+ # The X11 shim below does not affect the browser's fingerprint or functionality.
+ if use X ; then
+ echo "#include <stdlib.h>
+ void gdk_wayland_display_get_wl_compositor() { abort(); }
+ void gdk_wayland_device_get_wl_pointer() { abort(); }
+ void gdk_wayland_window_get_wl_surface() { abort(); }
+ void gdk_wayland_display_get_wl_display() { abort(); }" > "${S}"/X11shim.c
+ cc -shared -o "${S}"/mullvad-browser/X11shim.so "${S}"/X11shim.c
+ sed -i '1iexport LD_PRELOAD=/opt/mullvad-browser/X11shim.so' "${S}"/mullvad-browser/Browser/start-mullvad-browser
+ fi
+
+ insinto /opt/
+ doins -r "${S}"/mullvad-browser
+
+ dosym "../../opt/mullvad-browser/Browser/start-mullvad-browser" /usr/bin/${PN}
+ domenu "${S}"/mullvad-browser/start-mullvad-browser.desktop
+ local x
+ for x in 16 32 48 64 128; do
+ newicon -s ${x} "${S}"/mullvad-browser/Browser/browser/chrome/icons/default/default${x}.png mullvad-browser.png
+ done
+
+ fperms +x "/opt/mullvad-browser/Browser/start-mullvad-browser"
+ fperms +x "/opt/mullvad-browser/Browser/mullvadbrowser"
+ fperms +x "/opt/mullvad-browser/Browser/mullvadbrowser.real"
+}