aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-02-16 07:45:14 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-02-16 07:45:36 +0200
commit4aa001cbded0defaf57fe10632d2c257ec1f2cd5 (patch)
tree31edc131a5352d276076f5548291b815c01ae1e5
parentdev-util/rye: add 0.24.0, drop 0.23.0 (diff)
downloadguru-4aa001cbded0defaf57fe10632d2c257ec1f2cd5.tar.gz
guru-4aa001cbded0defaf57fe10632d2c257ec1f2cd5.tar.bz2
guru-4aa001cbded0defaf57fe10632d2c257ec1f2cd5.zip
dev-python/survey: add 5.2.2
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--dev-python/survey/Manifest1
-rw-r--r--dev-python/survey/survey-5.2.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/survey/Manifest b/dev-python/survey/Manifest
index a3fc7b0f6..1a0a17b92 100644
--- a/dev-python/survey/Manifest
+++ b/dev-python/survey/Manifest
@@ -1,2 +1,3 @@
DIST survey-4.5.4.tar.gz 831109 BLAKE2B 00065211437f4c6c820aca5c511395625da7be9415218d6261005aff946b19a3e65cc31189a6aef755ed88ce81f309ac2eabe23ea7f1e2f359007b4fe9172f96 SHA512 045989ca95e3fa9a840ad8d37a040f46bf3f22a858dd7b826fecf88d4e53b6b14e285ef3bf266add496da2d5ffd58971c2456b4375362e24c1a071fc910a03f4
DIST survey-5.2.0.gh.tar.gz 1564637 BLAKE2B 7e08c24515ce45ddd3630bbb6d182ec5d27bf80fbd54d6b64c6d9a24da0ab6bc54f74ebad74156622736790b6c45810f949d760ec4a4e32e399f297ff3a64722 SHA512 1d822e0597d96a5054547fc41b2a0d480dfe4939945a6fe3206a066b61ae0448c9ff898c251a271f281c97d54d456389df60cb09a9521d5d94a1e1407af4beb7
+DIST survey-5.2.2.gh.tar.gz 1564646 BLAKE2B 61a388f985617816daffabcd70bd5e1fcd3bcdfc3adabc3c7bfabd6abaad5e94e817da349e779d91131d2e6328b4548824fdc6ebd18456b99a5c49f952481d83 SHA512 bacdf14efe9f511d0a0b98d4404bf9d223267f999ce15f5d9533573aba12982a60508447158321c688685793660099c9ad16b52e34d36c43c5045e2855438645
diff --git a/dev-python/survey/survey-5.2.2.ebuild b/dev-python/survey/survey-5.2.2.ebuild
new file mode 100644
index 000000000..def53569b
--- /dev/null
+++ b/dev-python/survey/survey-5.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="A simple library for creating beautiful interactive prompts"
+HOMEPAGE="
+ https://github.com/Exahilosys/survey
+ https://pypi.org/project/survey/
+"
+MY_PV=${PV/_/-}
+SRC_URI="https://github.com/Exahilosys/survey/archive/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinx-paramlinks \
+ dev-python/sphinx-rtd-theme
+
+src_configure() {
+ distutils-r1_src_configure
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}