aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-01-13 20:43:14 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-01-13 20:59:33 +0900
commit9a234a637dbcd8cf5c45e04318575d7b1b5fed1e (patch)
tree151b0d3fac3c24473358455c9bcdaa016ca83b2d
parent*/*: move {sys-devel → dev-debug}/gdb (diff)
downloadguru-9a234a637dbcd8cf5c45e04318575d7b1b5fed1e.tar.gz
guru-9a234a637dbcd8cf5c45e04318575d7b1b5fed1e.tar.bz2
guru-9a234a637dbcd8cf5c45e04318575d7b1b5fed1e.zip
gui-apps/corearchiver: add 4.5.0, live sync
Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
-rw-r--r--gui-apps/corearchiver/Manifest1
-rw-r--r--gui-apps/corearchiver/corearchiver-4.5.0.ebuild30
-rw-r--r--gui-apps/corearchiver/corearchiver-9999.ebuild17
3 files changed, 37 insertions, 11 deletions
diff --git a/gui-apps/corearchiver/Manifest b/gui-apps/corearchiver/Manifest
index f7f128533..0be27b70a 100644
--- a/gui-apps/corearchiver/Manifest
+++ b/gui-apps/corearchiver/Manifest
@@ -1 +1,2 @@
DIST corearchiver-4.2.0.tar.gz 103411 BLAKE2B 6d336b5975d6a5e9a4a24239bf503a04c32c967297266d0dc2344a4e1b15b2a4924bfbbe88b83e685e9a09d09416c416a3d789760c74eb28488e484565a168a1 SHA512 f978aebd01f8a3a35c505df4d5be381d85df82461a30fb59f93ec1b560c3c3a70228f2f52b216f8426082c4736dc612f45f08ec4a5128a337b2599bff3189abb
+DIST corearchiver-v4.5.0.tar.bz2 106993 BLAKE2B 12a03ecb423ff9ad31a035b5a8ff5e439bcbed1e48bc39819c0815ad0b3b32c883ce59006b1b8e063a969919754d16ce5b19b14a5000815ed9d55511933dd98d SHA512 69f181b65352f1161304e3469ab7b5980b310d071a710342dedb0cf1b6d28440366134075fc13b09fec86dc80d19e52c896141a2d516bc43ea3d5f0db6f678da
diff --git a/gui-apps/corearchiver/corearchiver-4.5.0.ebuild b/gui-apps/corearchiver/corearchiver-4.5.0.ebuild
new file mode 100644
index 000000000..8a8bd7907
--- /dev/null
+++ b/gui-apps/corearchiver/corearchiver-4.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg cmake
+
+DESCRIPTION="Archiver for C Suite, to create and extract archives"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/corearchiver"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/corearchiver.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/corearchiver/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ app-arch/libarchive-qt
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+"
+RDEPEND="${DEPEND}"
diff --git a/gui-apps/corearchiver/corearchiver-9999.ebuild b/gui-apps/corearchiver/corearchiver-9999.ebuild
index 3cdc66d62..8a8bd7907 100644
--- a/gui-apps/corearchiver/corearchiver-9999.ebuild
+++ b/gui-apps/corearchiver/corearchiver-9999.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-MY_PV="${PV/_/-}"
+EAPI=8
inherit xdg cmake
@@ -12,14 +10,13 @@ HOMEPAGE="https://gitlab.com/cubocore/coreapps/corearchiver"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/corearchiver.git"
else
- SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.com/cubocore/coreapps/corearchiver/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-v${MY_PV}"
+ S="${WORKDIR}/${PN}-v${PV}"
fi
-RESTRICT="test"
LICENSE="GPL-3"
SLOT="0"
@@ -30,6 +27,4 @@ DEPEND="
dev-qt/qtwidgets:5
gui-libs/libcprime
"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="${DEPEND}"