aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Duarte <gonegrier.duarte@gmail.com>2023-08-29 15:29:58 +0100
committerGonçalo Duarte <gonegrier.duarte@gmail.com>2023-08-29 15:35:28 +0100
commitb6d69cb7b14825c44a3e00b5ff4505656e520f55 (patch)
tree0de4d414f2aaad83deacda1acb4e443a48599d4c
parentsys-firmware/lenovolegionlinux: fix python build error (upstream change) (diff)
downloadguru-b6d69cb7b14825c44a3e00b5ff4505656e520f55.tar.gz
guru-b6d69cb7b14825c44a3e00b5ff4505656e520f55.tar.bz2
guru-b6d69cb7b14825c44a3e00b5ff4505656e520f55.zip
media-sound/yewtube: new package, add 2.10.4, 9999
Signed-off-by: Gonçalo Duarte <gonegrier.duarte@gmail.com>
-rw-r--r--media-sound/yewtube/Manifest1
-rw-r--r--media-sound/yewtube/metadata.xml12
-rw-r--r--media-sound/yewtube/yewtube-2.10.4.ebuild38
-rw-r--r--media-sound/yewtube/yewtube-9999.ebuild38
4 files changed, 89 insertions, 0 deletions
diff --git a/media-sound/yewtube/Manifest b/media-sound/yewtube/Manifest
new file mode 100644
index 000000000..f28fea426
--- /dev/null
+++ b/media-sound/yewtube/Manifest
@@ -0,0 +1 @@
+DIST v2.10.4.tar.gz 120377 BLAKE2B 5689de2d5e386aa13689c68c7be2a86fc61561070e432638e0f5076f31163b5d0ce746489a4d1be3d50c72de370a462e25abb8914b565e5c8d749d817cde4163 SHA512 9d6a40a63c4c4502280544832507d6ca4fd70acd901b6e0b42e619c154f26f6c5aca4279890572fe41a02d5ba7255278ad6574f987f0743412236c4a3ec28b1f
diff --git a/media-sound/yewtube/metadata.xml b/media-sound/yewtube/metadata.xml
new file mode 100644
index 000000000..700b8188d
--- /dev/null
+++ b/media-sound/yewtube/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gonegrier.duarte@gmail.com</email>
+ <name>Gonçalo Negrier Duarte</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">mps-youtube</remote-id>
+ <remote-id type="github">mps-youtube/mps-youtube</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/yewtube/yewtube-2.10.4.ebuild b/media-sound/yewtube/yewtube-2.10.4.ebuild
new file mode 100644
index 000000000..e32f91cbd
--- /dev/null
+++ b/media-sound/yewtube/yewtube-2.10.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mps-youtube/yewtube.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/mps-youtube/${PN}/archive/refs/tags/v${PV}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Terminal-based YouTube player and downloader"
+HOMEPAGE="https://github.com/mps-youtube/yewtube https://pypi.org/project/yewtube/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ media-video/ffmpeg
+ dev-python/requests
+ dev-python/pyperclip
+ =net-misc/yt-dlp-2023.07.06
+ =dev-python/youtube-search-python-1.6.6
+ dev-python/pylast
+ || ( media-video/mplayer media-video/mpv )"
+
+src_compile() {
+ distutils-r1_src_compile --build-dir "${WORKDIR}/${P}"
+}
+
+src_install() {
+ distutils-r1_src_install --build-dir "${WORKDIR}/${P}"
+}
diff --git a/media-sound/yewtube/yewtube-9999.ebuild b/media-sound/yewtube/yewtube-9999.ebuild
new file mode 100644
index 000000000..e47d14389
--- /dev/null
+++ b/media-sound/yewtube/yewtube-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mps-youtube/yewtube.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/mps-youtube/${PN}/archive/refs/tags/v${PV}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Terminal-based YouTube player and downloader"
+HOMEPAGE="https://github.com/mps-youtube/yewtube https://pypi.org/project/yewtube/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ media-video/ffmpeg
+ dev-python/requests
+ dev-python/pyperclip
+ net-misc/yt-dlp
+ dev-python/youtube-search-python
+ dev-python/pylast
+ || ( media-video/mplayer media-video/mpv )"
+
+src_compile() {
+ distutils-r1_src_compile --build-dir "${WORKDIR}/${P}"
+}
+
+src_install() {
+ distutils-r1_src_install --build-dir "${WORKDIR}/${P}"
+} \ No newline at end of file