aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-01-30 21:21:04 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-01-30 21:21:04 +0900
commitfb418d595e2ef4f05b7a21c473cdbaa0093bdcaf (patch)
treeafc02182b6d18f375532be7d10ffb10eee0ff014
parentmedia-libs/gl4es: move {dev-util → dev-debug}/apitrace (diff)
downloadguru-fb418d595e2ef4f05b7a21c473cdbaa0093bdcaf.tar.gz
guru-fb418d595e2ef4f05b7a21c473cdbaa0093bdcaf.tar.bz2
guru-fb418d595e2ef4f05b7a21c473cdbaa0093bdcaf.zip
dev-python/pytest-*: force <pytest-8 for now
Closes: https://bugs.gentoo.org/923330 Closes: https://bugs.gentoo.org/923331 Closes: https://bugs.gentoo.org/923332 Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
-rw-r--r--dev-python/pytest-cases/pytest-cases-3.8.2.ebuild2
-rw-r--r--dev-python/pytest-harvest/pytest-harvest-1.10.4.ebuild2
-rw-r--r--dev-python/pytest-steps/pytest-steps-1.8.0.ebuild2
3 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/pytest-cases/pytest-cases-3.8.2.ebuild b/dev-python/pytest-cases/pytest-cases-3.8.2.ebuild
index 7d635e99d..48fc153a4 100644
--- a/dev-python/pytest-cases/pytest-cases-3.8.2.ebuild
+++ b/dev-python/pytest-cases/pytest-cases-3.8.2.ebuild
@@ -31,9 +31,11 @@ RDEPEND="
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
+# https://github.com/smarie/python-pytest-cases/issues/330
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/pytest-harvest[${PYTHON_USEDEP}]
dev-python/pytest-steps[${PYTHON_USEDEP}]
diff --git a/dev-python/pytest-harvest/pytest-harvest-1.10.4.ebuild b/dev-python/pytest-harvest/pytest-harvest-1.10.4.ebuild
index 293c2e1d4..505a08ccb 100644
--- a/dev-python/pytest-harvest/pytest-harvest-1.10.4.ebuild
+++ b/dev-python/pytest-harvest/pytest-harvest-1.10.4.ebuild
@@ -24,11 +24,13 @@ RDEPEND="
>=dev-python/makefun-1.5[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
+# https://github.com/smarie/python-pytest-cases/issues/330
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
dev-python/pytest-cases[${PYTHON_USEDEP}]
dev-python/tabulate[${PYTHON_USEDEP}]
)
diff --git a/dev-python/pytest-steps/pytest-steps-1.8.0.ebuild b/dev-python/pytest-steps/pytest-steps-1.8.0.ebuild
index 57301eca5..e62ca23f4 100644
--- a/dev-python/pytest-steps/pytest-steps-1.8.0.ebuild
+++ b/dev-python/pytest-steps/pytest-steps-1.8.0.ebuild
@@ -23,11 +23,13 @@ RDEPEND="
>=dev-python/makefun-1.5[${PYTHON_USEDEP}]
dev-python/wrapt[${PYTHON_USEDEP}]
"
+# https://github.com/smarie/python-pytest-cases/issues/330
BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
dev-python/pytest-cases[${PYTHON_USEDEP}]
dev-python/pytest-harvest[${PYTHON_USEDEP}]
dev-python/tabulate[${PYTHON_USEDEP}]