aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber@sysrq.in>2021-05-05 05:42:48 +0500
committerAnna Vyalkova <cyber@sysrq.in>2021-05-05 05:43:07 +0500
commit58751e4b71e505ecb7ce686045d09929f4fcbcf5 (patch)
treed040a4d01756361c1a1a34abdaf60b2232007c3b /app-backup
parentgui-wm/dwl: add 0.2.1, drop 0.2 (diff)
downloadguru-58751e4b71e505ecb7ce686045d09929f4fcbcf5.tar.gz
guru-58751e4b71e505ecb7ce686045d09929f4fcbcf5.tar.bz2
guru-58751e4b71e505ecb7ce686045d09929f4fcbcf5.zip
app-backup/b2: disable failing tests
Closes: https://bugs.gentoo.org/783852 Signed-off-by: Anna Vyalkova <cyber@sysrq.in>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/b2/b2-2.1.0.ebuild13
-rw-r--r--app-backup/b2/files/b2-2.1.0-skip-integration-test.patch12
2 files changed, 10 insertions, 15 deletions
diff --git a/app-backup/b2/b2-2.1.0.ebuild b/app-backup/b2/b2-2.1.0.ebuild
index 78feaef03..86c355f36 100644
--- a/app-backup/b2/b2-2.1.0.ebuild
+++ b/app-backup/b2/b2-2.1.0.ebuild
@@ -10,7 +10,7 @@ DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
-DESCRIPTION="The command-line tool for BackBlaze's B2 product."
+DESCRIPTION="Command-line tool for BackBlaze's B2 product"
HOMEPAGE="https://github.com/Backblaze/B2_Command_Line_Tool"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
@@ -20,7 +20,6 @@ KEYWORDS="~amd64 ~x86"
PATCHES=(
"${FILESDIR}/${P}-nameclash.patch"
- "${FILESDIR}/${P}-skip-integration-test.patch"
)
RDEPEND="
@@ -34,7 +33,15 @@ RDEPEND="
distutils_enable_tests pytest
-pkg_postinst(){
+python_test() {
+ epytest \
+ --deselect test/integration/test_b2_command_line.py::test_integration \
+ --deselect test/unit/test_arg_parser.py::TestCustomArgTypes::test_parse_millis_from_float_timestamp \
+ --deselect test/unit/test_console_tool.py::TestConsoleTool::test_sync_exclude_if_modified_after_exact \
+ --deselect test/unit/test_console_tool.py::TestConsoleTool::test_sync_exclude_if_modified_after_in_range
+}
+
+pkg_postinst() {
elog "The b2 executable has been renamed to backblaze2 in order to"
elog "avoid a name clash with b2 from boost-build"
}
diff --git a/app-backup/b2/files/b2-2.1.0-skip-integration-test.patch b/app-backup/b2/files/b2-2.1.0-skip-integration-test.patch
deleted file mode 100644
index 40506bc9b..000000000
--- a/app-backup/b2/files/b2-2.1.0-skip-integration-test.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/test/integration/test_b2_command_line.py b/test/integration/test_b2_command_line.py
-index 02b36ab..bd790ec 100644
---- a/test/integration/test_b2_command_line.py
-+++ b/test/integration/test_b2_command_line.py
-@@ -870,6 +870,7 @@ def main():
-
-
- # TODO: rewrite to multiple tests
-+@pytest.mark.skip(reason="Cannot do this in portage")
- def test_integration():
- application_key_id = os.environ.get('B2_TEST_APPLICATION_KEY_ID')
- if application_key_id is None: