aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKim Sindalsen <gentoo@vlh.dk>2024-05-10 19:09:53 +0200
committerKim Sindalsen <gentoo@vlh.dk>2024-05-10 19:09:53 +0200
commitd80e14aac829588425edd1f46cb175ce558efe42 (patch)
treee73c72203517cbd6eeafa58d64494c7e57d738dd /app-crypt
parentgames-util/mangohud: use the same version as subproject (diff)
downloadguru-d80e14aac829588425edd1f46cb175ce558efe42.tar.gz
guru-d80e14aac829588425edd1f46cb175ce558efe42.tar.bz2
guru-d80e14aac829588425edd1f46cb175ce558efe42.zip
Added python3_12 compat
Signed-off-by: Kim Sindalsen <gentoo@vlh.dk>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/PBinCLI/PBinCLI-0.3.5-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-crypt/PBinCLI/PBinCLI-0.3.5-r1.ebuild b/app-crypt/PBinCLI/PBinCLI-0.3.5-r1.ebuild
new file mode 100644
index 000000000..84a50ae13
--- /dev/null
+++ b/app-crypt/PBinCLI/PBinCLI-0.3.5-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="PBinCLI is a command line client for PrivateBin written in Python 3"
+HOMEPAGE="https://github.com/r4sas/PBinCLI"
+SRC_URI="https://github.com/r4sas/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/sjcl[${PYTHON_USEDEP}]
+ dev-python/base58[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"