aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Elbert <kcelbert@gmail.com>2024-06-18 23:47:01 -0500
committerKyle Elbert <kcelbert@gmail.com>2024-06-18 23:47:01 -0500
commitf85c75b2e22c0c81704f1cf510be97b670d9bf68 (patch)
tree08951d08fee2e693dc0a6bebb4f8c2edecc31f0f /app-crypt
parentgui-apps/darkman: Fix systemd user unit installation (diff)
downloadguru-f85c75b2e22c0c81704f1cf510be97b670d9bf68.tar.gz
guru-f85c75b2e22c0c81704f1cf510be97b670d9bf68.tar.bz2
guru-f85c75b2e22c0c81704f1cf510be97b670d9bf68.zip
app-crypt/certbot-dns-cloudflare: adjust cloudflare requirement
No longer blocked by cloudflare 3, just needs the most recent 2.x Signed-off-by: Kyle Elbert <kcelbert@gmail.com>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-dns-cloudflare/certbot-dns-cloudflare-2.10.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/certbot-dns-cloudflare/certbot-dns-cloudflare-2.10.0-r1.ebuild b/app-crypt/certbot-dns-cloudflare/certbot-dns-cloudflare-2.10.0-r1.ebuild
new file mode 100644
index 0000000000..90ae3f52bd
--- /dev/null
+++ b/app-crypt/certbot-dns-cloudflare/certbot-dns-cloudflare-2.10.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=(python3_{10..12})
+#DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
+
+MYPN="certbot"
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/${MYPN}/archive/v${PV}.tar.gz -> ${MYPN}-${PV}.gh.tar.gz"
+ KEYWORDS="~amd64"
+ S=${WORKDIR}/certbot-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Cloudflare DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="${CDEPEND}
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/dns-lexicon[${PYTHON_USEDEP}]
+ =dev-python/cloudflare-2.19*[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme