aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2023-08-29 11:01:04 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2023-08-29 11:01:04 +0400
commit1bbbf8a16dcd49836f45836c6ce071c55d31fcc2 (patch)
tree50ef96b7b01ea1b26076e99e804686da1a35e3fe /app-doc
parentapp-admin/linode-cli: drop 5.42.0 (diff)
downloadguru-1bbbf8a16dcd49836f45836c6ce071c55d31fcc2.tar.gz
guru-1bbbf8a16dcd49836f45836c6ce071c55d31fcc2.tar.bz2
guru-1bbbf8a16dcd49836f45836c6ce071c55d31fcc2.zip
app-doc/geeknote: new package, add 9999
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/geeknote/files/completion.patch29
-rw-r--r--app-doc/geeknote/geeknote-9999.ebuild34
-rw-r--r--app-doc/geeknote/metadata.xml12
3 files changed, 75 insertions, 0 deletions
diff --git a/app-doc/geeknote/files/completion.patch b/app-doc/geeknote/files/completion.patch
new file mode 100644
index 000000000..fdc60cedf
--- /dev/null
+++ b/app-doc/geeknote/files/completion.patch
@@ -0,0 +1,29 @@
+diff --git i/setup.py w/setup.py
+index 5cd1e35..a2618ab 100755
+--- i/setup.py
++++ w/setup.py
+@@ -24,22 +24,22 @@ class full_install(install):
+ ),
+ (
+ "zsh-completion-dir=",
+ None,
+ "(Linux only) Set zsh completion directory (default: /usr/local/share/zsh/site-functions)",
+ ),
+ ]
+
+ def initialize_options(self):
+ install.initialize_options(self)
+- self.bash_completion_dir = "/etc/bash_completion.d"
+- self.zsh_completion_dir = "/usr/local/share/zsh/site-functions"
++ self.bash_completion_dir = "${D}"
++ self.zsh_completion_dir = "${D}"
+
+ def run(self):
+ if sys.platform.startswith("linux"):
+ self.install_autocomplete()
+ install.run(self)
+
+ def install_autocomplete(self):
+ def copy_autocomplete(src, dst):
+ try:
+ if os.path.exists(dst):
diff --git a/app-doc/geeknote/geeknote-9999.ebuild b/app-doc/geeknote/geeknote-9999.ebuild
new file mode 100644
index 000000000..fd032c8c1
--- /dev/null
+++ b/app-doc/geeknote/geeknote-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Evernote CLI"
+HOMEPAGE="https://github.com/Evernote/evernote-sdk-python3"
+EGIT_REPO_URI="https://github.com/jeffkowalski/geeknote"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="dev-python/evernote3[${PYTHON_USEDEP}]
+dev-python/html2text[${PYTHON_USEDEP}]
+dev-python/sqlalchemy[${PYTHON_USEDEP}]
+dev-python/markdown2[${PYTHON_USEDEP}]
+dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+dev-python/thrift[${PYTHON_USEDEP}]
+dev-python/lxml[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ eapply "${FILESDIR}"/completion.patch
+
+ default
+}
+
+python_install_all() {
+ distutils-r1_python_install_all --bash-completion-dir="${D}"/etc/bash_completion.d
+}
diff --git a/app-doc/geeknote/metadata.xml b/app-doc/geeknote/metadata.xml
new file mode 100644
index 000000000..7a077c173
--- /dev/null
+++ b/app-doc/geeknote/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jeffkowalski/geeknote</remote-id>
+ <bugs-to>https://github.com/jeffkowalski/geeknote/issues</bugs-to>
+ </upstream>
+</pkgmetadata>