aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Holcomb <alex@alexsdigital.rodeo>2022-01-15 15:58:48 -0600
committerAlexander Holcomb <alex@alexsdigital.rodeo>2022-01-15 15:58:48 -0600
commit843a3c0bcae661da652bc42c91c391de45885787 (patch)
tree5f5ec8155b3fe220664505dc331d7add47ab8239 /app-editors
parentapp-misc/tealdeer: filter out -flto to avoid undefined references; (diff)
downloadguru-843a3c0bcae661da652bc42c91c391de45885787.tar.gz
guru-843a3c0bcae661da652bc42c91c391de45885787.tar.bz2
guru-843a3c0bcae661da652bc42c91c391de45885787.zip
app-editors/mined: Add new package
This adds a package for the MinEd text editor. The test suite is RESTRICT-ed because it will throw a QA message if used, due to an upstream make jobserver issue. If removed, it will still complete, but a QA error will show. The make process uses the -j1 option for the same reason. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alex Holcomb <alex@alexsdigital.rodeo>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mined/Manifest1
-rw-r--r--app-editors/mined/metadata.xml14
-rw-r--r--app-editors/mined/mined-2015.25.ebuild26
3 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/mined/Manifest b/app-editors/mined/Manifest
new file mode 100644
index 000000000..c3938b90a
--- /dev/null
+++ b/app-editors/mined/Manifest
@@ -0,0 +1 @@
+DIST mined-2015.25.tar.gz 6919430 BLAKE2B 5176cbafff1c427ea773546b43951e4d58a8b007448b42ee2fe478ed0b66230f48d6bc12d7a88fdec5d0c12c599d02527f4989d3ccf77e80ddcb81d5b285e9d0 SHA512 24c9313c26ffb00daab7754e42666bb9cf095c3246255b2b44cdb8eb8e325306ef40db03a828a8dad85d3bf406b874d17920365cfbf8c507f909eb97cfe480ea
diff --git a/app-editors/mined/metadata.xml b/app-editors/mined/metadata.xml
new file mode 100644
index 000000000..cbc0bcde2
--- /dev/null
+++ b/app-editors/mined/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex@alexsdigital.rodeo</email>
+ <name>Alex Holcomb</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>http://towo.net/mined/</bugs-to>
+ </upstream>
+ <longdescription>
+ Mined is a flexible terminal-based text editor, designed to be easy to use while still being lightweight.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-editors/mined/mined-2015.25.ebuild b/app-editors/mined/mined-2015.25.ebuild
new file mode 100644
index 000000000..79ac97d1c
--- /dev/null
+++ b/app-editors/mined/mined-2015.25.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A powerful text editor with extensive Unicode and CJK support"
+HOMEPAGE="http://towo.net/mined/"
+SRC_URI="https://downloads.sourceforge.net/project/mined/mined/mined%202015.25/mined-2015.25.tar.gz?ts=gAAAAABhfF-EKWvxGfwH7tpfR0NI8LV87Muimvh4jUigxZZZAD1fN8xgcbBPJc1TQ3f8djMFDbHXXz6rQZI4_qwwEsqakvBpqg%3D%3D&r=https%3A%2F%2Fsourceforge.net%2Fprojects%2Fmined%2Ffiles%2Fmined%2Fmined%25202015.25%2Fmined-2015.25.tar.gz%2Fdownload -> mined-2015.25.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND=""
+#src_configure() {
+# econf
+#}
+src_compile() {
+ emake -j1
+}
+src_install() {
+ dobin bin/Linux.x86_64/mined
+ doman man/mined.1
+}